Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a small notebook that i was using a previous version of ubuntu on and it worked perfectly until i did a clean install with the latest 12.10. I install ubuntu by usb since the notebook has no cd drive. I am not duelbooting, only ubuntu is on this notebook.

Everything seems to be installing perfectly until i get an error when it tries to install the bootloader. I did a little google searching and saw it was common so i decided to proceed without the bootloader and install in manualy later. However when i tried to install it later from the codes that i found online using the terminal, i get no luck.

I am only a newbe to linux and the terminal even tho i have used ubuntu for a while, it has mostly been used for travel and leasure. ie:internet and films

If anyone can help it be most appreciated as i am not sure what i am doing wrong. What i have tried so far is installing the bootloader by booting into the live usb and using the terminal there, but to be honest i am unsure what i am doing.

Thanks

K.

share|improve this question
1  
What is the error? What commands have you used? Be specific –  Paul van Schayck Feb 5 '13 at 11:05
add comment

1 Answer

You can boot your netbook with SuperGrubDisk from a USB-Stick. When your Ubuntu is booted, open a terminal and type:

sudo update-grub
sudo grub-install /dev/sda

The first command updates the bootloader settings, the second one installs it to the first hard drive (or ssd or whatever).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.