Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have two workspaces: WS1 and WS2.

On WS1, the script below is running in a konsole:

for i in 1..1000; do

    xterm -e someprogram argX &;
    xterm -e someprogram argY
; done

When I switch to WS2, these xterms starts to show up in WS2. Wherever I am, new windows always pop up on the active workspace. It distract a lot. How can I manage this? I dont want to remove xterm -e, because once in a while I want to compare outputs of the two commands.

share|improve this question
    
If anything, your window manager is the one that is responsible to take care of this. Which window manager or desktop environment are you using? Then, it may be the case that some window managers can't really track xterm: the one I use, i3wm, (by default?) only offers that support for applications that have the "startup notification", effectively creating any other new window in the workspace you are when it is created. –  njsg Feb 5 '13 at 6:05
    
I use gnome classic. how can I find out if I use i3wm or not? xterm has an option called -maximized, if it had a -minimized option it would do it. –  Emmet B Feb 5 '13 at 6:23
    
GNOME by default uses the gnome's own window manager. So, unless you explicitly tried to change the wm, you're using GNOME's own wm. Sure, a -minimized would prevent it from starting opened, but it would still start on the current desktop; if what bugs you is the window appearing in top of what you are doing and you just want to background it, I'd suggest changing the question to reflect that. –  njsg Feb 5 '13 at 7:38

1 Answer 1

up vote 0 down vote accepted

Ok I found it.

Solution is to add -iconic

Example:xterm -iconic -e someprogram ArgX

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.