Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I Currently Have a Running server with multiple KVMs running different Servers within each, now I would like to add another separate interface to serve another group of KVMs on the same server.

There are Currently Three Nic cards in the Box

Nic 1 -- Lan 1 -- Host only

Nic 2 -- Lan 1 -- br0 for the first set of KVMs

Nic 3 -- Lan 2 -- br1 for the second set of KVMs

When I run this one of the Bridges shuts down, normally br0 taking the entire first set offline.

This is my current interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth1
iface eth1 inet static
    address 192.168.1.20
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 8.8.8.8 4.2.2.6 8.8.4.4
    dns-search firezen.com

auto eth0
iface eth0 inet manual

auto br0
iface br0 inet static
        address 192.168.1.21
        network 192.168.1.0
        netmask 255.255.255.0
        broadcast 192.168.1.255
        #gateway 192.168.1.1
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0
        bridge_maxwait 0

iface eth2 inet manual

#auto br1
#iface br1 inet static
#        address 192.168.1.57
#        network 192.168.1.0
#        netmask 255.255.255.0
#        broadcast 192.168.1.255
#        gateway 192.168.1.1
#        bridge_ports eth2
#        bridge_stp off
#        bridge_fd 0
#        bridge_maxwait 0

#auto br1
#iface br1 inet dhcp
#        bridge_ports eth2
#        bridge_stp off         < This was what I was using lastly, could not get 
#        bridge_fd 0                 the above to work.
#        bridge_maxwait 0

Both networks are 192.168.1.x based. If you need any other information Please let me know, and Thank you in advanced.

share|improve this question
    
You're asking something impossible here. Both LANs sharing the same IP addresses is asking for trouble. You'll have to disregard any IPv4 connectivity in LAN2 on the host if you want to have LAN1 active on it as well. –  gertvdijk Feb 4 '13 at 23:44
add comment

1 Answer

up vote 0 down vote accepted

As "Both networks are 192.168.1.x based" is a plain IP conflict, you'll have to disable IPv4 in one of those networks on the host. You can still bridge it to VMs, but you'll have to make a choice or redesign your network here. There's absolutely no need to use the same address space in the wide range of RFC1918 addresses you're free to use.

The other mistake is the line iface eth2 inet manual while you also use it in the bridge interface. The below should work, I've only touched lines below the br0 section. Don't forget to properly shut down the eth2 and br1 interfaces first (ifdown eth2, ifdown br1), before you edit it and bring it up again (ifup br1 only!).

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth1
iface eth1 inet static
    address 192.168.1.20
    netmask 255.255.255.0
    network 192.168.1.0
    broadcast 192.168.1.255
    gateway 192.168.1.1
    # dns-* options are implemented by the resolvconf package, if installed
    dns-nameservers 8.8.8.8 4.2.2.6 8.8.4.4
    dns-search firezen.com

auto eth0
iface eth0 inet manual

auto br0
iface br0 inet static
        address 192.168.1.21
        network 192.168.1.0
        netmask 255.255.255.0
        broadcast 192.168.1.255
        #gateway 192.168.1.1
        bridge_ports eth0
        bridge_stp off
        bridge_fd 0
        bridge_maxwait 0

auto br1
iface br1 inet manual
        bridge_ports eth2
        bridge_stp off
        bridge_fd 0
        bridge_maxwait 0
share|improve this answer
    
Thank you, Can I get you to explain the "you'll have to disable IPv4 in one of those networks on the host. You can still bridge it to VMs, but you'll have to make a choice or redesign your network here" Redesigning I would guess would be changing the IP space, would a simple change such as a 10. IP? or even 192.168.0.x?, none the less the above has gotten the system back up, I thank you! –  Randy Kupel Feb 5 '13 at 0:03
    
Well, you got a plain IPv4 address conflict there. Once you have networks coming together like this, you know you're doing something wrong. If you have the chance to re-assign addresses to one of the LANs, please do that. (I suggest to read more about how IPv4 and subnetting works and you'll understand) Now we're just disabling IPv4 (the manual line) and the host only "knows" about layer 2 (MAC addresses). –  gertvdijk Feb 5 '13 at 0:07
    
Will do, Just have to figure out which will be easier, But Thanks again for the advice and the help, I really appreciate. –  Randy Kupel Feb 5 '13 at 0:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.