Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm working in 10.04 Lucid. All my video players (Movie Player and VLC) and the preview windows in editors (OpenShot and Pitivi) will only display a black screen when playing a video. The sound is fine and the videos work fine on other computers.

I have tried multiple formats from varying sources .MOV taken from old ffmpeg projects, .AVI straight from a camera, .MP4 using h.264 from OpenShot on another system, .OGV from a gtk-recordmydesktop session on this very computer. I even get a pure black screen in the viewer when starting a remote session in VNC.

This box has a GeForce 8400 GS using the proprietary Nvidia drivers in case it may be a card problem or setting.

share|improve this question
    
Are you using the proprietary Nvidia drivers or the Xorg Nvidia drivers? Also, have you tried disabling Compiz or other eye-candy? –  jwernerny Feb 7 '11 at 18:53
    
Nvidia. Yes to no effect. –  Dennis Feb 7 '11 at 19:07
1  
I'm at a loss. The best suggestions I have is try re-installing the drivers or trying the non-proprietary nv driver. If the problem is still there with the nv driver, then it is most likely not a driver issue. Good Luck. –  jwernerny Feb 8 '11 at 15:33
1  
Removing and reinstalling the Nvidia drivers did the trick, why don't you post an answer and I'll accept it. Linking to a post of the process would be a plus for future folks finding this. –  Dennis Feb 8 '11 at 18:12
    
...because it was a complete long-shot :-) –  jwernerny Feb 9 '11 at 13:30
add comment

2 Answers 2

up vote 2 down vote accepted

I'm at a loss. The best suggestions I have is try re-installing the drivers or trying the non-proprietary nv driver. If the problem is still there with the nv driver, then it is most likely not a driver issue.

Good Luck

share|improve this answer
1  
There is not doubt a nice fast command line way to do this. However wanting to try it quick without a lot of research I went to System > Administration > Hardware Drivers found the Nvidia driver and clicked remove which required a restart. Then tested it and all video was fine. Next I went to System > Preferences > Appearance and tried to restore some of the effects which prompted me to re-install the proprietary drivers. I did, re-started, turned all effects back on, and the video still worked. Don't know if it is a universal fix, but in "one man's experience..." –  Dennis Feb 9 '11 at 15:23
    
Did not work for me unfortunately... –  Laurent Pireyn Sep 13 '11 at 19:40
add comment

I found this worked.

  1. Open the Configuration Editor by running

    gconf-editor 
    

    in the terminal.

  2. Navigate to system → gstreamer → 0.10 → default

  3. Double-click on videosink and change the setting from autovideosink to ximagesink

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.