The last update of PostgreSQL 9.1.7 seems to break my APT.
When I try to update, I get the following error:
Reading package lists... Done Building dependency tree Reading state information... Done You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: postgresql : Depends: postgresql-9.1 but it is not going to be installed postgresql-contrib-9.1 : Depends: postgresql-9.1 (= 9.1.7-0ubuntu12.04) but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
I tried to run
apt-get -f install, same error.
Finally, I tried to remove everything using
apt-get --purge remove postgresql, same error again.
Note: I installed PostgreSQL using the following PPA: https://launchpad.net/~pitti/+archive/postgresql