Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The last update of PostgreSQL 9.1.7 seems to break my APT.

When I try to update, I get the following error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 postgresql : Depends: postgresql-9.1 but it is not going to be installed
 postgresql-contrib-9.1 : Depends: postgresql-9.1 (= 9.1.7-0ubuntu12.04) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I tried to run apt-get -f install, same error.

Finally, I tried to remove everything using apt-get --purge remove postgresql, same error again.

Note: I installed PostgreSQL using the following PPA: https://launchpad.net/~pitti/+archive/postgresql

Thanks.

share|improve this question
    
Anyone to help me? –  OyoKooN Feb 5 '13 at 19:18
    
Try aptitude. You probably have to install it first. When you run it, there should be a category of packages with unmet dependencies and you should be able to work them out there. –  Jack Feb 6 '13 at 6:52
add comment

1 Answer

up vote 0 down vote accepted

Check the FAQs. They have a lot of good answers to these kinds of questions.

How do I resolve unmet dependencies?

share|improve this answer
    
Thanks for the help! –  OyoKooN Feb 8 '13 at 21:13
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.