Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just performed a fresh install of 12.04LTS 64-bit, using the alternate CD, with LVM and LUKS. Install went fine but I've noticed a few quirks and was hoping for some pointers/suggestions from the community.


Issues:

  1. On boot, before entering encryption pass phrase, I get a message "ERROR: No video mode activated" (Everything seems to work fine though)
  2. I've got a noticeable but inconsistent "lag/delay" in the launcher/nautilus with the new load. The delay can sometimes be as much as 5+ seconds. Things like the compiz cube/rotator work very fast so I don't think it's a graphics issue.

NOTE: Neither of these issues were present in my original 32bit std install (using the disc from the "Ubuntu Unleashed 2012 edition" book.)

Question:

How do I get rid of the boot error (I'm guessing it's a config issue with grub)?

What would be the best way to further diagnose the "lag" that I'm experiencing?

  • I'm not sure if it's an issue with 64-bit Precise (though I seen several posts reporting the issue with no solutions) or full disk encryption. I know my CPU supports AES-NI, how do I determine if it's enabled/configured properly?

My system:

  • HP Z210 SFF Workstation
  • Intel Xeon E3-1245 quad-core, hyperthreaded
  • Integrated Intel HD 3000 Graphics (registering as "Intel Sandybridge Server" after installing mesa-utils)
  • 8GB RAM
  • 500GB HDD (LVM & LUKS configured using the wizard on the entire drive)

top:

top - 13:37:05 up  2:12,  2 users,  load average: 0.06, 0.21, 0.21
Tasks: 210 total,   1 running, 209 sleeping,   0 stopped,   0 zombie
Cpu(s):  0.1%us,  0.0%sy,  0.0%ni, 99.9%id,  0.0%wa,  0.0%hi,  0.0%si,  0.0%st
Mem:   8063752k total,  4227732k used,  3836020k free,    34392k buffers
Swap:  8269820k total,    53548k used,  8216272k free,  3418876k cached
share|improve this question
    
askubuntu.com/questions/2194/… –  Mateo Feb 4 '13 at 19:49
add comment

1 Answer 1

up vote 0 down vote accepted

The first is a known bug. There are suggested work arounds on the bug report

https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/699802

Most common is:

Commenting out GRUB_HIDDEN_TIMEOUT and GRUB_HIDDEN_TIMEOUT_QUIET in /etc/default/grub works for me.

GRUB_DEFAULT=GRUB_SAVED_DEFAULT
#GRUB_HIDDEN_TIMEOUT=10
#GRUB_HIDDEN_TIMEOUT_QUIET=
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
#GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

GRUB_TERMINAL=console

GRUB_GFXMODE=auto

I do not know the problem with nautilus, but this question has been asked with no obvious solution either. I doubt it has to do with either LVM or LUKS.

Nautilus is really slow

Nautilus is extremely slow

The most common problem is a network share (samba) that is not mounted.

Perhaps running nautilus from the command line might show an error of some kind.

share|improve this answer
    
Grub error fixed. Thanks for that! –  muldune Feb 4 '13 at 19:40
    
Looked into the other posts you listed. No luck there. I found no symlinks in root to network share (didn't expect any as this is a fresh install) and no assistive tech features are enabled. I'll keep looking. Thanks again! –  muldune Feb 4 '13 at 19:44
    
Best of luck, I did not see and obvious solution to your nautilus problem either. Hope somebody can help you. –  bodhi.zazen Feb 4 '13 at 19:55
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.