Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set up a panel (panel no.2, from 0,1,2 ) in xfce ubuntu, and I want it to be at desktop level - covered by windows. I found something about it on the archlinux wiki.

https://wiki.archlinux.org/index.php/Xfce ( ctrl+f "Panel at desktop level" )

So I did that, I created the script and run it on startup.

It took me a bit of playing until it started to work - when I set 2 as the parameter for the script. I was happy for a while, but after a restart the panel was showing over my windows again. So I played with it again, and it started to work when I set "5" as the parameter. Restart again, and same as before, panel2 is misbehaving again. Now, I tried to just guess-set the parameter to 8 (2+3=5, 5+3=8) , it did not work.

I would really appreciate, if I could just set it and enjoy it until I decide to change it. What is the reason the "right" parameters change? What did I mis-understand? Is there a better way to do it?

Thanks very much in advance.

share|improve this question

1 Answer 1

You might try enabling hiding for the panel, rather than using that startup script. The behavior won't be quite the same as having the panel at desktop level, since the panel will be hidden even if there are no windows to cover it. But it should be reliable.

share|improve this answer
    
Yes, I have it set up that way right now, but it is more of a temporary solution - you would understand better why I want it like this if you saw what I'm trying to do. –  user46061 Feb 14 '13 at 9:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.