Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu from a bootable USB drive on an old machine. The graphical interface is using up all the memory and I actually just need a terminal.

Is there a way to not start the desktop environment from a live OS image?

share|improve this question

2 Answers 2

When GRUB is loading, shortly after the BIOS finishes loading, quickly press shift or esc. This should allow you to boot the recovery mode.

share|improve this answer
    
I did as you said, and it seemed to work for the first few seconds. Too bad it quickly switched to graphical mode without my consent. ;) –  Ricky Robinson Feb 5 '13 at 10:13

UEFI + Ubuntu-14.04.1-desktop-amd64

With a UEFI boot (without CSM enabled in firmware), the media boots into a GRUB menu.
UEFI booting can be troublesome, some firmware has the tendency to change from UEFI to BIOS boot in between reboots. Other times the USB stick needs to be plugged in a different port after each boot for the firmware to recognize it.

When you see a graphical (not text) Ubuntu boot screen it is likely that your firmware has enabled CSM and in effect disabled UEFI boot. Go back in your firmware and re-enable the (ultra) fast boot mode.

By default *Try Ubuntu without installing is selected in the GRUB menu.

  1. Press e to edit this line.

  2. Move your cursor to the b of boot=casper after vmlinuz.efi
    using the arrow keys and

  3. Type (insert) the word text and a space there.

  4. Press F10 to boot.


You might want to replace the existing quiet splash with text to get rid of the graphical splash screen and see the dmesg output on screen.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.