Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This all started when I went to the nvidia website and got the latest driver for my GForce 555M. I downloaded and installed LINUX X64 (AMD64/EM64T) DISPLAY DRIVER, version 310.32. There were several errors, including it "not running" the pre installation script, and also many errors about not copying files. I can't remember exactly what it said as That was a while ago.

After rebooting, unity fails to load, and I get all the windows with no tops, and no taskbar. I might add that I have an optimus laptop. I realized I shouldn't have installed that, and I tried many things to fix it.

I previously had bumblebee installed, and I removed that in an attempt to fix.

When I use "unity" command from command line it tells me that my system isn't supported by unity. I know for a fact that it is "supported" because It was working before I installed the driver.

I also have done # apt-get purge nvidia* in an attempt to undo what I have done, but that didn't help.

When I do lspci -k | grep VGA, only my intel driver shows up. Before I was doing all this I had my intel driver and my GForce.

I have Ubuntu 12.10.

Any suggestions? I have looked everywhere and nothing has helped.

EDIT: I basically gave up on this issue and completely re installed ubuntu.

For future users who haven't already completely destroyed their systems with nvidia drivers: This is what I did after I re installed.

I did NOT do anything with nvidia-current or any other drivers, instead i ran:

sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get install bumblebee bumblebee-nvidia

After rebooting, and copying my personal files back into the new install, it works perfectly in a way I was never able to achieve before! I now have no errors with unity, and I can use optirun to run with the gforce driver. I never got bumble bee to work on my old operating system BTW. Probably because I had installed nvidia-current.

share|improve this question
up vote 1 down vote accepted

I experienced almost the same (very annoying) issue. I installed Bumblebee as suggested by I have a GT540M card.

The same happens with every kind of installation I tried (Nvidia drivers alone, Bumblebee with Nvidia drivers...) : Unity does not display anything but the mouse cursor, and the screen resolution is low. When Nvidia drivers were installed alone, uninstalling it via a command line (sudo apt-get remove nvidia*) solved the problem.

But with Bumblebee and linux-headers-generic, I tried reinstalling the kernel, booting on a previous kernel, nothing worked. Maybe I missed something, but I had to reinstall...

Nvidia is known for very good compatibility with Linux and good driver support. It is a real shame having the only system that is not supported by their own drivers. You know what? Even on Windows, although an old driver installed properly, the newest (310) said that it does not recognize the card. Absurd.

So, numerous posts have been written about these Optimus graphics cards, but they are not reliable as it may depend on the card model and the system. The worst of it is when it does not work, you may have to reinstall.

The freeze and black screen with Nouveau error messages, when using the Unity dash, was the symptom of the recognized Nvidia Optimus card, with disabled Optimus in BIOS, with no Nvidia driver.

My solution : I finally switched back my BIOS setting to ENABLE Optimus (named Lucid Virtu on my machine) and Ubuntu does not see the Nvidia card. This is back to basics, and it seems to work fine with the Nouveau driver, until then. I will post again if I I see the Unity freeze again. Edit: No, it does the same. Unity freezes after several uses of the dash. I can only wait for a fix...

share|improve this answer
I will look into bios settings to see if I have Optimus disabled, though I don't believe I ever have. After doing quite a bit on my own system, right now it is not recognizing the nvidia card at all, according to lspci -k | grep VGA. I think I might just re install ubuntu with mroe hard drive space and that will probably fix it. – DaboRoss Feb 5 '13 at 18:09
When I re installed and didn't touch the nvidia drivers it worked. I never saw an optimus option on my bios either though :P, and I know my system is optimus. – DaboRoss Feb 15 '13 at 10:24

I don't recommend using Nvidia drivers from their site, I (and a lot of people) never managed to make it work (I have a Geforce 635M and Ubuntu 12.10).

You mentioned you had Bumblebee installed but I didn't quite understand why you removed it and attempted to install Nvidia's drivers. I strongly recommend using Bumblebee. It is a bit of annoyance to do always optirun <program> but for now I think it's the best option. Anyway, you will most likely need it for a couple of programs.

If you need help uninstalling Nvidia drivers or installing bumblebee, here's a similar question which has a compreehensive answer: How well do laptops with Nvidia Optimus work?

share|improve this answer
I have tried the steps in that post in trying to fix this, to no avail. – DaboRoss Feb 5 '13 at 18:11
I think after installing the nvidia drivers, it won't work until re install. I had to before it worked. – DaboRoss Feb 25 '13 at 2:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.