Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to open the disk tray in Lubuntu 12.10 and nothing is happening. This can't be a mechanical failure because it works fine in Windows XP, and I'm posting it here because there are no packages I know of related to disk trays at all. I can also open the tray when I'm in the BIOS, so I must be missing a driver.

share|improve this question
    
With "disk tray", are you referring to an optical disc drive tray? If so, what does sudo eject -i off && sudo eject do? And no, there are no drivers for optical drives. –  gertvdijk Feb 3 '13 at 21:03
    
@gertvdijk Yes. The command you asked me to try does open the optical drive. I guess I could make that button run that command. –  user1610406 Feb 3 '13 at 21:12
    
Some application on your machine might lock it and that's why the sudo eject -i off works - this forces an unlock command. Try to find out what application causes this: CD burning applications, media players, etc. –  gertvdijk Feb 3 '13 at 21:16
    
The only applications that I can see blocking it are Xfburn, Gnome MPlayer, and Audacious. I killed all running instances while they were running, and tried hitting the button again, still no result. –  user1610406 Feb 3 '13 at 21:22
    
Killing an application after it has sent this "lock" command will keep it locked and just cause this issue. Gracefully closing such an application should release this lock. It's hard to tell which application causes this from here. –  gertvdijk Feb 3 '13 at 21:29
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.