Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04 running Cinnamon desktop. I tried to reboot, and now I get an error and the system halts.

The error is:

> Starting nanny (Parental Control Daemon):
> /usr/lib/python2.7/dis-packages/gtk-2.0/gtk/__init.py:57:  GtkWarning:
> could not open display warnings.warn(str(e), _gtk.warning)
> ** (twistd:2023):  Warning**: Command line'dbus-launch --autolaunch-0e42ec90e8137a7c8d6a1cc00000005 --binary-syntax --close-strerr' exited with non-zero exit status1: Autolaunch error: x11 initialization failed.\n

When I try to go through recovery, and remount the hard drive as read-write fsck runs and just stops.

Any ideas?

share|improve this question
1  
fsck starting and stalling looks like a known bug in recovery. Go to "root shell" and type mount / -o remount,rw. Then exit that shell and try again. –  guntbert Feb 3 '13 at 18:38
    
@guntburt I would put this as an answer. May be more helpful to the OP. –  nerof61 Feb 6 '13 at 15:54
add comment

1 Answer

up vote 1 down vote accepted

Fixed it. The problem was the hard drive was full, and XServer couldn't start. I freed up some free space and the problem went away.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.