Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04LTS trough Wubi on Win7. Later have installed Skype 4.1. When I make a video call I can hear and see the other person fine, but when I start my camera, the image of the incoming video call starts flashing between blue and normal video (the same for my mirror image in the little square). The other person sees me fine.

I use Intel 82852/855GM Integrated Graphics Device if that is relevant anyhow.

I found that people have same problem, but solution is found. More information in Skype bugs on launchpad.

share|improve this question
    
Thanks for editing, but it does not work for me. –  Gdin.Ne Feb 6 '13 at 23:12
    
same problem here - I guess it is an intel 82852 problem. –  gromgull Mar 17 '13 at 16:26
    
Maybe then it is not bad idea to vote up our problem so someone can help us? –  Gdin.Ne Mar 20 '13 at 1:11

2 Answers 2

For me worked using the nomodeset option in the grub bootloader. There are two methods to set "nomedest":

  1. Temporal: while booting press and hold shift in order to see the grub menu. Choose the entry you want to change (in a normal installation the first entry) and press e to edit it. Look for quiet splash" and add "nomodeset before it. Finally press F10 to boot. If this worked for you, you can use the permanent way for all bootups.
  2. Permanent: edit "/etc/default/grub" (for example: sudo nano /etc/default/grub): change the line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash". Finally update the grub config: sudo update-grub. The next time rebooting, you don't have to specify the boot option.

The problem is, now the graphics adaptor isn't as adaptable anymore (on a wide screen it has standard ratio resolution stretched to wide screen) and the graphics are sometimes lagging.

share|improve this answer

I've discovered a really crappy work-around, if you move the contacts window (or any window) over the part of the chat window showing YOUR video (the small thumbnail in the corner) the flickering stops.

Somehow the problem is related to showing both the video thumbnail and the remote video at the same time.

I've also tried upgrading xserver-xorg-video-intel from 2.9 to 2.15, changing between uxa and sna acceleration, and setting the XvPreferOverlay xorg option to true - none make a difference.

It doesn't happen with the fbdev driver - but it is unable to render more than 1fps full-screen video.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.