Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The difference between this issue and other threads about: "login screen loop" is that in my case it's a finite loop which means it runs five times and then I can type my password and start my session.(I'm not stuck in loop at the login screen) Check my video.

After my session start ubuntu randomly log me out (I can see the ubuntu crash dialog box). It happened frequently when I was using nautilus with dropbox applet opening tabs and saving in text files but also when I was just using Chrome. Deluge torrent is ending randomly and I've seen the ubuntu crash dialog box too.

It seems that started after my last update about two days ago. full update history.log file

I tried : sudo dpkg --configure -a; sudo apt-get update; sudo apt-get upgrade and restart

also: sudo apt-get install --reinstall xorg and restart

[Important]

Since I ran that last command to re-install xorg yesterday ubuntu seemed stabilized (for 24h) until it logged me out today. It kept randomly ending my session and going to login screen finite loop until I decided to run sudo apt-get install --reinstall xorg again and restart. So I think this issue is related to X server and/or my graphic driver.

Since it started last weekend after an update I began to search inside my history.log ($ gedit /var/log/apt/history.log) for some package related to Xorg or Xserver. I found xserver-xorg-video-intel Version: 2:2.19.0-0ubuntu1~xup1 and decided to update (or downgrade) it.

My VGA is:

$ lspci -vv
00:02.0 VGA compatible controller: Intel Corporation Core Processor Integrated Graphics Controller (rev 02) (prog-if 00 [VGA controller])
    Subsystem: Hewlett-Packard Company Device 3658
    Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
    Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
    Latency: 0
    Interrupt: pin A routed to IRQ 43
    Region 0: Memory at d0000000 (64-bit, non-prefetchable) [size=4M]
    Region 2: Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Region 4: I/O ports at 5050 [size=8]
    Expansion ROM at <unassigned> [disabled]
    Capabilities: <access denied>
    Kernel driver in use: i915
    Kernel modules: i915

I change my server mirror and ran:

$ sudo dpkg --configure -a; sudo apt-get update; sudo apt-get upgrade

after that the last version change to 2:2.21:

$ apt-cache show xserver-xorg-video-intel | grep "Version"
Version: 2:2.21.0+git20130204.9640640a-0ubuntu0ricotz~precise
Version: 2:2.19.0-0ubuntu1~xup1
Version: 2:2.17.0-1ubuntu4.2
Version: 2:2.17.0-1ubuntu4

at last I re-installed xorg:

$ sudo apt-get install --reinstall xorg

but without too much luck. Yesterday the session was taking more time to crash but today is crashing all the time.

I'm going to change the xorg version and see what happens:

$ apt-cache show xorg | grep "Version"
Version: 1:7.6+12ubuntu2
Version: 1:7.6+12ubuntu1 

p.s. Similar threads:

Why is my ubuntu damaged after updating xserver-xorg-video-intel package? 12.04 login loop - Gnome Session crashes back to Login - Ubuntu Keeps ending my session - Unity spontaneously logs out in Ubuntu 12.04 - Login crash loop

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

[Solution]

I looked carefully at the (above) update history.log file and I found some non-official xorg xserver packages versions installed:

$ apt-cache show xserver-xorg-video-intel | grep "Version"
Version: 2:2.21.0+git20130204.9640640a-0ubuntu0ricotz~precise
Version: 2:2.19.0-0ubuntu1~xup1
Version: 2:2.17.0-1ubuntu4.2
Version: 2:2.17.0-1ubuntu4

like xserver-xorg-video-intel Version: 2:2.21.0+git20130204.9640640a-0ubuntu0ricotz~precise.

I remembered that I was added a non-official PPA xorg-edgers “xorg crack pushers” team they're responsible for xserver-xorg-video-intel 2:2.21.0+git20130204.9640640a-0ubuntu0ricotz~precise and I suspected that should be the issue.

So I removed the PPA xorg-edgers:

Ubuntu Software Center > edit > Software Sources > Other Software

removed all packages related of xserver and xorg:

sudo apt-get remove --purge xserver-xorg-video-intel
sudo apt-get remove --purge xorg
sudo apt-get remove --purge xorg-*
sudo apt-get remove --purge xserver-xorg-core
sudo apt-get remove --purge xserver-*

clean apt cache:

sudo apt-get autoclean; sudo apt-get clean;

reinstall xorg and ubuntu-desktop:

sudo apt-get install xorg ubuntu-desktop

and restart.

Back to ubuntu-desktop UI I reset lightdm, xserver-xorg and unity configurations:

sudo dpkg-reconfigure lightgdm
sudo dpkg-reconfigure -phigh xserver-xorg
unity --reset

My ubuntu is stable once again! (^-^)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.