Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Since upgrading to 12.10 and what is presumably a newer version of Evolution (I never checked on 12.04) I have been having serious and annoying problems using Evolution.

Just reading emails can be painfully slow. When I open Evolution for the first time, it is unusable for several minutes using 100% CPU and just displaying the message:

Retrieving Message.....

Until it finally displayed the message it is on. After that the inbox works OK. However, if I try switching to another folder or searching, or using a search folder, the same result. I have to wait 4-5 minutes (no exaggeration) either for the result or for it to display the first message clicked on. Again, once it has done all the message load immediately when clicked. It seems like it is trying to load all the messages in the folder at once, or re-index them all again every time I click a folder, rather than just having a slight delay when each message is clicked on, like it used to.

Also if I click Send and Receive, the same thing happens, it hangs using 100% CPU but invariably either crashes or needs to be killed without ever completing a Send and Receive, ergo the Send and Receive button is useless to me now.

None of this happened in 12.04, or indeed in any other version of Evolution that I have used for the best part of a decade. It was always smooth, fast and reliable. Is there a way of getting Evolution to work the way it did in 12.04? i.e. load messages as required rather than re-loading the whole folder each and every time I click on that folder. Or is there an update or upgrade not yet available in the repos that can restore this once brilliant piece of software back to being usable again?

I am using Ubuntu 12.10, Evolution 3.6.2

share|improve this question
    
Evolution 3.6.2 hasn't made it into a backport for quantal yet. Have you tried rolling back to default 3.6.0 in quantal, or were you encouraged to go the 3.6.2 for another reason? –  Kevin Bowen Feb 4 '13 at 10:53
    
I was using 3.6.0 up until a few days days ago and unfortunately have had these problems since I installed 12.10, then 3.6.2 came through via Update Manager so I eagerly updated hoping it would solve all my problems. However it didn't make any difference whatsoever, everything was just the same, so I thought I'd post here. –  user99306 Feb 4 '13 at 17:42
    
Is it Imap+? might be cached connections too high or low, or an issue with exchange imap and imap-pipeline mode. I had this issue mainly with the OWA plugin back in the day. –  rupert Mar 28 '13 at 3:11
    
Thanks for the response. But no, it isn't IMAP just standard POP inboxes (I have several email addresses) that are affected. –  user99306 Mar 28 '13 at 12:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.