Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get the following error while installing Battles of Wesnoth:

 **/var/cache/apt/archives/wesnoth-1.8-data_1%3a1.8.6-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)**

I tried to solve it by running sudo apt get install -f. But still I get the same message. I tried to run the game, put sudo apt-get upgrade -f but still no result. So please give me some advice on how to solve the issue.

share|improve this question

1 Answer 1

Probably the archive is corrupted, delete that deb and run sudo apt-get install -f

sudo rm /var/cache/archives/filename.deb

share|improve this answer
    
I initiated the commands, but couldn't find the archive –  Jakob Chaplata Feb 10 '13 at 12:51
    
Replace file name.ded with filename in the error message, Alternatively try sudo apt-get update; sudo apt-get clean; sudo apt-get install -f –  Tachyons Feb 10 '13 at 12:54
    
still not working get the problem that setting dpkg was killed by a process call –  Jakob Chaplata Feb 10 '13 at 14:21
    
Can you post exact error message –  Tachyons Feb 10 '13 at 15:23

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.