Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.10 with gnome 3.6. It was working fine. But now after I installed some updates of gnome, I am unable to successfully login into Ubuntu. The Ubuntu boots up normally and after loading the wallpaper it hangs up. Nothing else is shown in the desktop. Alt+F2 doesn't work. Ctrl+Alt+F2 is working.

How can I resolve this problem? Is it possible to login into Unity desktop, if gnome has caused this problem?

Thanks.

share|improve this question

2 Answers 2

At the login screen you can sign in to Unity. Follow the steps to get logged in fine.

enter image description here

As you can see, that Ubuntu Logo is circled. Click on it, and you will see this:

enter image description here

You should see 'Ubuntu'. Select it and click 'OK >'. Then sign in as normal.

Note: Once you click 'Ubuntu' Unity will be your default theme until you change it. To change the theme use the steps above.

Hope this helps!

share|improve this answer
    
But I am not using a password for login. Its automatic login. So this login screen doesn't appear for me.Can I use some terminal commands to login to unity environment, since only the terminal works for me now. –  Tinto Varghese Feb 4 '13 at 3:48

The same is happening for me...in 3 different machines: my home machine, and 2 machines in my workplace (one of them is a VM).

At home I'm logging in using Cinammon now. It's nice, but it's not what I want, I want gnome-shell.

At work I'm logging into Gnome Classic (no effects).

What I did was open screen terminal 1 (CTRL+ALT+F1) and killall gnome-session. After that the login screen is shown, and then I chose the new default session (either Cinnamon or Gnome Classic with no effects.

share|improve this answer
    
I tried killall gnome-session command. When I executed it I got the log in screen. I tried logging in to Unity as well as the other three gnome options. But in all of them wallpaper loads and hangs. Nothing else is seen. Then I tried log in as a guest user. It was successful on Unity, gnome(with no effects) and gnome(classic). When I logged in, I could see the list of the last installations and updates that I have installed. Is there any way to remove those updates? I think some of those updates has created me this problem. –  Tinto Varghese Feb 9 '13 at 1:54
    
Hi, this is what I found: there were messages "gnome-shell-cal trap int3" and "gnome-shell.desktop respawning too quickly" in the system log. Following that hint, I tried find something that I had uninstalled that could have caused the problems (I usually try to uninstall everything related to "evolution", for example). In the end, I just removed "gnome-shell" and re-installed it again (with "synaptic"). You know what ? It worked! –  José Vitor Feb 9 '13 at 11:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.