Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just built this Mini-ITX computer to use Ubuntu exclusively and the motherboard "FM2-A75IA-E53" has built in wireless (with a small connector in the back and a supplied antenna). However Ubuntu doesn't seem to be picking it up at all.

At the moment I'm using a USB wireless adapter but preferably I'd like to use the built in adapter, does anyone have any ideas as to drivers I could download to try and resolve this? I've tried installing MadWIFI following these instructions but to no avail.

Any help would be appreciated, thank you.

share|improve this question
add comment

1 Answer

At the link you gave above, I downloaded the WLAN driver and it appears your device is an Atheros device driven by the driver ath9k_htc. It requires firmware that is not installed by default. Using the USB, get an internet connection and open a terminal and do:

sudo apt-get install linux-firmware

Reboot and see if your device is working. If not, edit your question to add the results of these commands:

lsusb
dmesg | grep ath9

The pipe symbol | is on the right side of my US keyboard on the same key with backslash.

share|improve this answer
    
Hi thanks for the answer, I'll try it soon and let you know if it worked. :) –  EM-Creations Feb 4 '13 at 16:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.