Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am currently trying to setup wine properly in Ubuntu 12.10. The error that I am trying to fix is:

p11-kit: couldn't load module: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: /usr/lib/i386-linux-gnu/pkcs11/gnome-keyring-pkcs11.so: cannot open shared object file: No such file or directory"

I have found several Posts here which say that I have to create a symlink to the 32bit lib but when I look for /usr/lib32 on my system then I see that I dont have any lib32 directory.

I tried to install the 32 libs with:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install ia32-libs

Terminal says I have already the newest version. But I still don't have any /usr/lib32 directory.

I hope anyone can help me with that issue.

share|improve this question
    
You're probably looking into outdated information. Ubuntu has Multiarch since 11.10, so you don't want to install ia32-libs, but the libraries you need as 32-bit, e.g. sudo apt-get install gnome-keyring:i386. That package contains this very missing file. See this answer for more about Multiarch. (not sure if that solves your issue, so posting as a comment) –  gertvdijk Feb 2 '13 at 10:57
    
Ok, this explains my issue at least a bit. But how can I find out which i386 Libraries I need now and how can I install them? –  MeiSign Feb 2 '13 at 11:03
    
Oh I forgot to mention. I tried to install the gome-keyring:i386 but I got this error: gnome-keyring:i386 : Depends: libcap-ng0:i386 but it is not going to be installed Depends: libgck-1-0:i386 (>= 3.3.90) but it is not going to be installed Depends: libgcr-3-1:i386 (>= 3.5.3) but it is not going to be installed Depends: gcr:i386 (>= 3.4) but it is not going to be installed Ok I update the question. –  MeiSign Feb 2 '13 at 11:26
    
Good question now. :) I can reproduce this on my system as well. –  gertvdijk Feb 2 '13 at 11:48
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.