Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My laptop is Dell Vostro 2520. I tried both Xubuntu and Ubuntu on it, I've used 12.04 & 12.10. WiFi fails to work in all the cases - when i try to switch WiFi by a hotkey (fn+f2) the Bluetooth icon appears in the system tray but the light for the WiFi on lower left corner panel doesn't turn on.
I tried the solution of connecting to the network via cable:

sudo apt-get install linux-headers-generic
sudo apt-get install --reinstall bcmwl-kernel-source
sudo modprobe wl

from the similar thread Ubuntu 12.10, Wireless not working

Could you help me?
Many thanks in advance!

Update 1
It wasn't clear to me is @mikewhateve talking about one or two commands in the console. i tried both

halfros@halfros-Vostro-2520:~$ lspci -nn | grep Net, rfkill list all
grep: rfkill: No such file or directory
grep: list: No such file or directory
grep: all: No such file or directory
halfros@halfros-Vostro-2520:~$ lspci -nn | grep Net
07:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365] (rev 01)
halfros@halfros-Vostro-2520:~$ rfkill list all

Update 2

$ sudo dpkg -i | grep bcmwl-kernel-source
dpkg: error: --install needs at least one package archive file argument

Type dpkg --help for help about installing and deinstalling packages [*];
Use `dselect' or `aptitude' for user-friendly package management;
Type dpkg -Dhelp for a list of dpkg debug flag values;
Type dpkg --force-help for a list of forcing options;
Type dpkg-deb --help for help about manipulating *.deb files;

Options marked [*] produce a lot of output - pipe it through `less' or `more' !

Update 3

 dpkg -l grep bcmwl-kernel-source
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
ii  grep           2.12-2       amd64        GNU grep, egrep and fgrep
dpkg-query: no packages found matching bcmwl-kernel-source
share|improve this question
Can you add the outputs of the following to the question: lspci -nn | grep Net, rfkill list all. To get the outputs, open a terminal window, copy paste a command, and hit Enter. – mikewhatever Feb 2 '13 at 9:33
Yes, thank you. i'll do that. I worked on the desktop ubuntu/xubuntu for quite a while now. But the first time i'm setting up a laptop. – Elmor Feb 2 '13 at 9:39
So, it's a BCM43142. It should actually work in 12.04.2 now, with the very recently updated bcmwl-kernel-source version, but I don't think that 12.10 will get it. You can check the installed version with dpkg -l | grep bcmwl-kernel-source. If it's an older version, deactivate it, and try this question. – mikewhatever Feb 2 '13 at 10:00
please see update 2 – Elmor Feb 2 '13 at 10:21
dpkg -l <--that's a small L, not i and not one, though they look very similar indeed. Copy/paste, and everything will be ok. – mikewhatever Feb 2 '13 at 10:38
up vote 1 down vote accepted

Thanks @mikewhatever the answer was found. i copy it here to save time for anyone interested in this issue

If you have a 64-bit system and the device I mentioned, then I suggest this package:

First install the prerequisites:

sudo apt-get install linux-headers-generic build-essential dkms

Then install the package with:

 cd Desktop   <--or whemikewatrever you downloaded the deb
    sudo dpkg -i wire*.deb
    sudo modprobe wl
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.