Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Chrome works alright on my netbook except when opening and closing tabs. Opening a tab is pretty slow. Is this normal behavior or can I fix it?

I am using the latest dev version but the problem isn't unique to a version. It's always like this.

share|improve this question
    
what kind of processor do you have? Memory? –  Jason Mar 26 '13 at 5:05
add comment

5 Answers

Well, since Google chrome opens a new processes for each new tab, it may be related to limitations of using a low powered cpu notebook in that situation. For example, in firefox, since each new tab will run off of generally the same processes, there won't be a huge leap in resource usage when opening a new tab. Chrome, on the other hand, uses a seperate process for each new tab or new site (depending on your configuration), and also a separate process for things like plugins for audio and flash. As a result, opening new tabs may have a higher initial cost, which may really become evident on a low power processor like a notebook.

Personally, where chrome isn't a great fit, I tend to devolve back to firefox since it (currently) works on close to a single process model and will tend to be easier on resources as a result (though more prone to sites crashing your session, etc).

share|improve this answer
add comment

Type about:flags in the address bar of chrome, and then disable "GPU compositing on all pages" Then restart Chrome for the changes to take effect.

While I experienced the issue I noticed the GPU process in chrome was eating up all the memory, once I disabled this the tabs stopped hanging. Haven't had issues since.

share|improve this answer
add comment

Do the other tabs that exist have some flash or shockwave animation running in them?
Even I have observed the same, but none of the browsers run them it is fine.

share|improve this answer
add comment

Type about:flags in the address bar and enable "Web Page Prerendering" which Speculatively prerenders complete webpages in the background for a faster browsing experience.

share|improve this answer
add comment

This can be caused by extensions. Try disabling all extensions and see if it works any better.

share|improve this answer
    
This is really a comment, not an answer to the question. Please use "add comment" to leave feedback for the author. –  Mitch Aug 23 '12 at 8:16
    
@Mitch This is telling the author a specific course of action to take, which may solve the problem. This answer would be better if it explained exactly how to disable browser extensions (perhaps with a screenshot to accompany descriptive text), but this is undoubtedly an answer, not a comment. –  Eliah Kagan Sep 6 '12 at 15:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.