Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

All of a sudden there's this message of 'couldn't load plug-in' on chrome. Firefox is fine though, I tried updating flashplayer but it didn't work. Thoughts?

share|improve this question

closed as off-topic by Braiam, fossfreedom Feb 8 at 22:36

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – fossfreedom
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Very, very similar thread here: Google Chrome - couldn't load plugin - shockwave flash and a link to code.google.com/p/chromium/issues/detail?id=173790. It's still flagged as "unconfirmed" despite several me-toos. –  user25656 Feb 2 '13 at 3:09
5  
It's now "untriaged" but this comment explains the problem: "Unfortunately, 11.5.31.138 was pushed out via the component updater, and using plugins from the component updater doesn't work on Linux (and breaks stuff, due to the way plugins are loaded). :( So deleting ~/.config/google-chrome/PepperFlash should fix things (unfortunately falling back to .137) ... and since we've stopped pushing .138, it won't reappear." –  user25656 Feb 2 '13 at 6:20
2  
@mlvljr - agree its annoying - yes its a bug which will be shortly fixed (see the triage comment link above) - hence, its both off-topic and too-localised. The 5K views would be expected. However I agree - I'll reopen for the moment - but in a few days when the bug is resolved, I'll close this again as too-localised since the question will be just for a specific moment in time. –  fossfreedom Feb 3 '13 at 21:24
2  
This is now supposedly fixed - can someone confirm? googlechromereleases.blogspot.co.uk/2013/02/… –  fossfreedom Feb 5 '13 at 12:18
1  
The bug has been fixed. I just did an update which included Google-Chrome. But, we have to go to /home/user/.config/google-chrome and rename (or delete) the PepperFlash folder. Then open Chrome browser, which will now load the plugin from the /opt/google/chrome/PepperFlash folder. The current version is 11.5.31.138. Then, if you had enabled the Adobe version, disable it in chrome://plugins –  Sri Feb 6 '13 at 5:52

9 Answers 9

I solved the issue by moving the following folder to a backup:

~/.config/google-chrome/PepperFlash moved to ~/.config/google-chrome/PepperFlash.bak

After that kill all processes of Chrome (also the background ones for offline gmail and so on).

It works now for me. Must have to do something with the new rule that you have to enable plugins per page/site before they run maybe?

share|improve this answer
    
I read about that but I thought it was only Firefox. –  Uri Herrera Feb 2 '13 at 6:04
1  
This is the correct answer, and gets your PEP plugin working again. –  mikaelhg Feb 2 '13 at 7:21
4  
Here is official issue discussion on google's tracker code.google.com/p/chromium/issues/detail?id=173790 –  Konstantin Burov Feb 2 '13 at 8:48
    
Worked for me too. –  Jobi Carter Feb 3 '13 at 6:24
    
It worked! On Ubuntu 12.10 and Chrome Version Version 24.0.1312.57. Thanks! –  Marquez Feb 3 '13 at 18:04
  1. Open up Google Chrome
  2. Type chrome://plugins into the address bar
  3. Look for Adobe Flash Player
  4. Click on +Details in the upper right corner
  5. Disable one of the Adobe Flash Player entries, and make sure one is Enabled

If you have installed the package flashplugin-installer you'll see two plug-ins, you can choose whichever you want.

For some reason it was disabled and at the beggining of the list you can also see another libpepflashplayer which is also disabled.

share|improve this answer
1  
I have this same issue and I have typed in the the about://plugins and everything is enabled and still get the error couldn't load plugin –  rstreeter78 Feb 2 '13 at 2:50
    
@rstreeter78 Is every flash plugin you have enabled? –  Uri Herrera Feb 2 '13 at 3:08
    
Yes I believe so here are links to the images imagebin.org/245133 imagebin.org/245134 –  rstreeter78 Feb 2 '13 at 3:27
    
@rstreeter78 Try with one plug in at a time they might be conflicting with each other. –  Uri Herrera Feb 2 '13 at 3:37
1  
I tried that and was unsuccessful –  rstreeter78 Feb 2 '13 at 3:54

In chrome://plugins, I disabled libpepflashplayer. Now I can watch youtube and Dateline. :D

share|improve this answer
    
oh..Just an update. OK to watch Dateline.. but can't watch on ABC.com. It's just blank... no error message. –  user127947 Feb 3 '13 at 4:38

I can't seem to add a comment to Uri Herrara's answer, or even up vote it. But he set me on the right track.

Ubuntu installed a new image and Chrome, and the libpepflashplayer.so Flash player is not working. I disabled it, and the

Name:   Shockwave Flash  
Version:    11.2 r202  
Location:   /opt/google/chrome/plugins/libflashplayer.so  

is working fine

share|improve this answer
    
If you want to learn more about how this site works, I suggest reading the FAQ and About pages. Good luck and have fun! –  Seth Feb 2 '13 at 5:14

Don't know why, but the pepperflash plugin used by chrome seems to be crashing recently. Removing the plugin completely will do the trick temporarily, but will be recreated automatically at some point in time, probably after a relaunch of the browser or something.

rm -fr ~/.config/google-chrome/PepperFlash

This is the command to remove the plugin. Launching chrome thereafter should allow you to play flash via it defaulting back to the default adobe plugin.

If you don't want to go around blowing away directories, you can rename it:

mv ~/.config/google-chrome/PepperFlash ~/.config/google-chrome/PepperFlash.bak

It works too.

Again, just a temporary work around, but it works in a pinch until they fix PepperFlash.

share|improve this answer

I was able to get flash playing again by just disabling libpepflashplayer in Chrome via chrome://plugins/, no terminal needed, didn't even restart Chrome. Strangely I did not have any issues with Firefox.

share|improve this answer
    
I was also thinking why would Firefox have an issue when the pepper flash is for Chrome only. Oddly enough it was the only step I did. –  Luis Feb 3 '13 at 19:51
    
Worked for me. Thank you. –  kedmond Feb 4 '13 at 22:04

Well got lucky. Did the following after closing both browsers. Go to a terminal and:

rm -r ~/.config/google-chrome/PepperFlash

Then open any of the 2 browsers and go to their respective plugins section.

For Firefox it is in the menu in Tools --> Addons --> Plugins and check to be sure that the Shockwave Plugin is Enabled. Then test any flash video.

For Chrome, type in the URL: chrome://plugins and check that the plugin is checked there as Always Enabled.

Right now am testing to make sure both are working fine.

UPDATE - Yeap, both are working correctly again. Maybe it was an update that left a confusion there with the PepperFlash file.

share|improve this answer

The new release, Version 24.0.1312.69 has fixed this.

share|improve this answer

It's simple go to chrome://plugins and disable /opt/google/chrome/PepperFlash/libpepflashplayer.so.

Everything works like charm.

share|improve this answer

protected by Community Feb 2 '13 at 8:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.