Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 12.04 and during the upgrade installation notices my wireless signal indicator go to "no wireless". Since the upgrade, I can ONLY access the internet via a wired connection or an UNSECURED wireless connection. I do not like leaving my home wireless unsecured, however that is now my only option unless I want to go buy a 25' long ethernet cable to give me the ability to sit somewhere beside the floor near where my router is located. Any ideas as to what may have happened and/or how I can fix this bug so I can secure my home network once again?

share|improve this question
    
What do you mean you cannot access secured wireless network? What happens if you try to connect? –  Xavier_Ex Feb 1 '13 at 22:27
    
My laptop automatically finds my home network (we'll call it network "x")and tries to connect but the "wave" keeps fluxing, indicating connection attempts but not success. Every now and then it will pop up that I am not connected to "x" network, then it will try again. If I am connected via ethernet and log into my router, disable the security, then unplug the ethernet, the wireless immediately connects. While connected wirelessly, if I go to the router and enable the security, I am immediately disconnected from the internet! –  morgan Feb 3 '13 at 0:01

1 Answer 1

You may try this:

Connect an ethernet cable, install updates, install Additional Drivers, reboot.

Then, open a terminal and type the following commands:

sudo apt-get purge broadcom-sta-common broadcom-sta-source bcmwl-kernel-source  
sudo apt-get install b43-fwcutter firmware-b43-installer

Restart again, and open up the "Network" program, and click the dropdown to select your network, and type your password.

Unplug the ethernet cable and see if you can now access your wireless network.

share|improve this answer
    
OK, tried that and this was my result: Reading package lists... Done Building dependency tree Reading state information... Done E: Unable to locate package apt-get E: Unable to locate package install –  morgan Feb 3 '13 at 0:11
    
E: Unable to locate package install Didn't exactly seem like the result I was looking for, but I rebooted again anyways and tried to access the wireless network with the same result I've been having. –  morgan Feb 3 '13 at 0:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.