Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  1. I am running on a Windows 7 64 bit host.
  2. Running VirtualBox 4.0.2
  3. Running Ubuntu 10.10 64 bit guest.
  4. Running VirtualBox Guest Additions 4.0.2 - I ran the 4.0.2 .run file i got from virtualbox downloads.
  5. Compiz/Emerald are installed.

This is driving me crazy. This should take 20 minutes to setup. But after 4 hours i need help.

share|improve this question
    
Do you have 3D acceleration enabled for the guest (Machine > Settings... > Display > Video tab > Enable 3D Acceleration)? –  htorque Feb 6 '11 at 17:07
    
yes. it is enabled and i still have the problem. –  user10314 Feb 7 '11 at 2:19
add comment

4 Answers 4

3D acceleration in Virtual Box still is experimental. Therefore not all combinations of hosts/guests are supported, some graphic funtions are not yet implemented, and some incompatibilites with the host graphic adapter still exist. In addition virtual emulation of a 3D graphic card consumes quite a lot of CPU power and slows down the guest system considerably.

In order to test 3D functionality you have to enable this manually in the settings of your virtual machine. Also a proper installation of guest additions is needed. You can test the latter in the guest Ubuntu from System -> Administration -> Additional Drivers. The guest additions driver should appear there as activated like this:

enter image description here

If you can't see this you need to reinstall your guest additions by running the installation script provided by the guest additions .iso file (see also this answer).

share|improve this answer
    
Thanks for the input. My Oracle VM VirtualBox Guest Additions For Linux Modules looks just like the screenshot provided. It is green and activated. 3D is activated in the VirtualBox Display settings. The problem still exists. –  user10314 Feb 7 '11 at 2:14
    
How much memory did you allocate for the virtual graphics adapter? Try with 128 MB (maximum). If that also fails your hardware may not be fully supported yet. –  Takkat Feb 7 '11 at 7:47
    
i have it set to max at 128. i guess a reinstall of the guest is the next step. –  user10314 Feb 7 '11 at 14:20
add comment

You will need at least VirtualBox 4.0.6 to run well Ubuntu 11.04. VirtualBox only added complete support to X.org 1.10 in this version, as you check in the changelog.

Older versions can run into graphical problems while running Natty.

share|improve this answer
add comment

I have the same problem with a Ubuntu 10.10 Desktop 64-bit guest running inside VirtualBox 4 on a Windows 7 64-but host. My host machine is a Sony Vaio F Series (VPCF11S1E). I have always had problems with Linux (even native installs) because of the quirky nVidia GeForce GT 330M graphics chipset.

When I right-click on the desktop, select "Change Background", click on the "Visual Effects" tab and then click the "Extra" radio-button, it searches for a driver but always responds with: "Desktop Effects Could Not Be Enabled".

I too have 3D acceleration selected and the max 128MB video RAM set.

Any help on this would be really appreciated.

share|improve this answer
add comment

I struggled with this as well. I finally got it to work by updating my Windows host graphics card driver. I was using the driver that came from Windows Update, but by going to my graphics card manufacturers website and downloading the latest driver, I was able to get 3d acceleration to work inside an Ubuntu guest.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.