Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Info: http://pastebin.com/raw.php?i=7qJ7BYBy

Ive got output from lsusb, lsmod, ifconfig and syslog there

What happens is that it can detect wireless networks but can't connect to them. It just keeps asking for the wifi password. I've tried both WEP and WPA2 Personal, both no luck.

This wifi device is a wifi dongle that seems to be using a Realtek chip as you can see from lsusb output. I really have no idea what's wrong with it because it is working fine in other OS. But I'd really like to use linux so I'm trying to get this to work.

Hope someone can help, thanks a lot.

share|improve this question
    
Which Ubuntu version are you running? lsb_release -d. –  chili555 Feb 1 '13 at 22:37
    
@chili555 12.04 LTS –  yowmamasita Feb 2 '13 at 1:53
add comment

1 Answer

There is an updated rtl8192xx driver available. Please get a temporary wired ethernet connection and do:

sudo apt-get install linux-backports-modules-cw-3.6-precise-generic

Reboot and tell us if the behavior has improved.

share|improve this answer
    
Im using quantal and the graphics messed up after installing this. Im using an Intel GPU –  yowmamasita Feb 6 '13 at 9:54
    
Quantal? Your response above says 12.04, not 12.10. "@chili555 12.04 LTS" –  chili555 Feb 6 '13 at 15:31
    
Im sorry, I am trying the dongle in 2 Ubuntu versions just to be sure. Latest Linux Mint (Nadia?) and Ubuntu quantal. –  yowmamasita Feb 6 '13 at 15:39
    
In Quantal, remove the incorrect package: sudo apt-get remove --purge linux-backports-modules-cw-3.6-precise-generic; install the correct one: sudo apt-get install linux-backports-modules-cw-3.6-quantal-generic. –  chili555 Feb 7 '13 at 2:28
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.