Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On 12.04, when I do apt-get install on postgresql (which is already installed), it returns an error that mentions rabbitmq-server. What are the circumstances that could cause this type of failure?

# apt-get install -y postgresql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
postgresql is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 80 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Setting up rabbitmq-server (2.7.1-0ubuntu4) ...
Starting rabbitmq-server: FAILED - check /var/log/rabbitmq/startup_{log, _err}
rabbitmq-server.
invoke-rc.d: initscript rabbitmq-server, action "start" failed.
dpkg: error processing rabbitmq-server (--configure):
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 rabbitmq-server
E: Sub-process /usr/bin/dpkg returned an error code (1)
share|improve this question
add comment

1 Answer

It turns out that rabbitmq-server could not start up because it couldn't resolve the hostname, so adding the appropriate line to /etc/hosts fixed it:

127.0.1.1 hostname.example.com hostname

I'm still not exactly sure what triggers the rabbit service start command after postgres installs.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.