Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP dv6-3160 with a "soft" trackpad e.g. the buttons are part of it.

Ubuntu 12.10 works well with it apart from when I want to drag+drop. Because the mouse movement area includes the buttons if I'm holding down the left button I can mess everything up just by a twitch of my left finger (I can of course use tap-to-click and then move things but only up!).

What I'd like to do is be able to set a "dead zone" - just stop all mouse movement in the button area (I have enough space above).

Installed the synaptics package and tried using synclient and setting BottomEdge but no matter what (valid - if I set it too low it errors) value I set it to the mouse behaviour doesn't change.

Many thanks in advance.

share|improve this question
    
Seems like you would have to patch the drivers themselves, if that's possible, to create the deadzone. That isn't a normal use case. –  Ken Feb 1 '13 at 18:56
    
It seems to work ok in Windows. Although the area does work as a mouse I think when you're clicking it doesn't respond to movement there. I can't think I'm the only one with this - it's a real pain. –  Dave Feb 1 '13 at 19:18

1 Answer 1

up vote 8 down vote accepted

I just ran into this problem myself and sadly it's a matter of RTFM, because it gets described in the manual pretty clearly (Look it up here: http://www.x.org/archive/X11R7.5/doc/man/man4/synaptics.4.html).

The relevant value is "AreaBottomEdge" and the manual says "Ignore movements, scrolling and tapping which take place below this edge. The option is disabled by default and can be enabled by setting the AreaBottomEdge option to any integer value other than zero." So to try it out you can do:

  1. Do a synclient -l | grep BottomEdge to find out your touchpads bottom edge.
  2. Let x be the value of BottomEdge minus the height of your wanted deadzone
  3. Do a synclient AreaBottomEdge=x
  4. For it to be permanent put it as an "Option" in the 50-synaptics.conf file (Don't know where it is on Ubuntu, I'm on Archlinux and there its /etc/X11/xorg.d/50-synaptics)

Anyway, hope this helps.

share|improve this answer
    
Note that, at least for my trackpad, the 'zero' value for this is actually at the top of the trackpad. So to lower the AreaBottomEdge line, you need to increase the number. –  Jeffrey Martinez Jun 3 at 1:29

protected by Community Oct 9 '13 at 7:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.