Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

buyed a new pc with a nvidia gt620m. Someone can help me to install the right drivers? thank you. It doesn't shown in the additional driver hardware

share|improve this question

1 Answer 1

up vote 0 down vote accepted
  1. Make sure you've run updates Fresh installs aren't always completely up to date, and they have to run once to figure out what all of your hardware is. Open Dash (either with the Windows/Super key or by clicking the Ubuntu icon in the upper left corner) and search for "Software Updater". It should automatically check for updates when you start it, then click the "Install Updates" button.

  2. Install Nvidia drivers from Additional Drivers On Linux, you will not find a driver named for your specific card. The Linux Nvidia drivers work for most Nvidia cards. Pick one of the ones that say "proprietary" to install a set of drivers from Nvidia (I recommend the one that says "stable, tested"). You'll likely be asked to restart, if you aren't, I recommend doing so anyway, as it's the easy way to activate the driver.

  3. Update your graphics settings. Once the driver is installed, it will likely change your settings to something crazy like 640x480. You'll want to change that by opening Dash and searching for "Nvidia Settings". Go to the "X Server Settings" section and change the resolution to something more sane.

share|improve this answer
    
Hi Shauna thank you. 1) Done 2) Nvidia drivers isn't in the list. Additional Drivers is blank. –  freddyparisi Feb 1 '13 at 19:13
    
Tried also bumblebee but it doesn't work –  freddyparisi Feb 2 '13 at 10:09
    
Make sure "Proprietary drivers for devices (restricted)" is checked in the "Ubuntu Software" tab of Software Sources, then run the software updater again and see if it appears then. Also, if you just want to use the Nvidia card, and don't want to use the other card, you can disable Optimus in your Bios settings. Just go into Bios when your computer first starts up, before Ubuntu loads, find the "Optimus" option and make sure it's disabled. This does, however, result in using the battery faster, due to the higher power draw of the Nvidia card. –  Shauna Feb 2 '13 at 19:57
    
Proprietary drivers for devices (restricted) is checked. In the BIOS I haven't settings about Nvidia card, this is a lot strange.Thank you –  freddyparisi Feb 3 '13 at 11:12
    
You won't see anything about Nvidia in the Bios, you need to look for "Optimus". –  Shauna Feb 3 '13 at 14:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.