Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I booted a few minutes ago and everything was fine, update manager notified me about new updates so I decided to install them, and then poof, dim/dark screen is back in action.

I did update grub, I did tried to remve fglrx but terminal said I don't even have it installed and the "classical" fix I used is the

sudo setpci -s 00:02.0 F4.B=01

It does work, but only till I reboot, I had same problem but I added this code before exit 0 from /etc/rc.local [gksudo gedit /etc/rc.local] now it's still here but it doesn't work. I also tried nomode set before booting, it resulted in a crash.

Any ideas how to fix it? And I would also want to know if I can get completely the rid of this thing? It always came back when the computer was idle or when I tried to run things in full screen mode.

Other info: I run it on an Acer Aspire 5732Z with Intel GMA 4500M (graphics accelerator) if this helps.

share|improve this question

Just press buttons Fn+Left Arrow or Right Arrow while booting starts and that's it!

If its for acer laptop.

share|improve this answer
oddly enough that worked for me! – Nocturno Oct 9 '13 at 15:31
Do you need to press the keys on every boot, or is the setting kept? – Volker Siegel Oct 16 '15 at 6:57

I was also having problems with suspend / resume in addition to the boot problem with a dimmed screen. The following 2 lines updated in /etc/default/grub fixed both of my issues.

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

Be sure to replace vendor with your_machine_vendor and run sudo update-grub

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.