Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This might not be a bug, but I've installed the Vim plugin package, spf13-vim.

My GVim window looks like this screenshot, which seems too big:

This might not be an issue with spf13-vim, since I've used it on Windows without problems. Can anyone point me in the right direction so that I can see, say, 40 lines on the window at once?

My current font within Vim is Sans size 10.

share|improve this question
    
Could someone re-post the image to imgur using StackExchange's uploader? The image is blocked where I am ATM. –  Flimm Apr 16 '13 at 12:05
    
Are you sure that is a size 10 font? It looks much larger. Place the following line in your ~/.gvimrc file: set guifont=Ubuntu\ Mono\ 10 –  Bert Apr 16 '13 at 12:33
    
Bert, you are right. The problem seems to be with the Sans font that appears so large even with the size of 10. I've switched to Ubuntu Mono with size 13 now and it works great. –  AgilE Apr 16 '13 at 16:41
add comment

1 Answer 1

In my .gvimrc file I have:

set lines=64
set columns=90

to set the initial window size.

This is for gvim, the GUI vim.

I don't know if it works in the console vim also.

You can also enter the :scriptnames command. It will show the list of the files sourced by vim at startup.
One of those files might be setting the window size you don't like. Check from last to first, because the settings might be in more than one file.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.