Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I fail to set all speakers to work on the Genius 5.1. (Such connected work well on Win 7). I tried with alsamixer and pulseaudio but I do not succeed.

aplay -l gives this:

**** List of PLAYBACK Hardware Devices ****
card 0: Generic [HD-Audio Generic], device 0: VT1705 Analog [VT1705 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 1: VT1705 Digital [VT1705 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Generic [HD-Audio Generic], device 2: VT1705 HP [VT1705 HP]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Generic_1 [HD-Audio Generic], device 3: HDMI 0 [HDMI 0]
Subdevices: 1/1
Subdevice #0: subdevice #0

Advance grateful for any suggestion.

share|improve this question
add comment

1 Answer

I found the solution for my problem, so, here is what I did.

Type in terminal:

gksudo gedit /etc/pulse/daemon.conf

change the line ;default-sample-channels = 2 in to default-sample-channels = 6.

Do not forget to remove the ; from the beginning of the line.

Restart the system, do a bit of settings in alsamixer and PulseAudio and everything will work just fine.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.