Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to install 12.10 alongside windows 7, but i am not getting an option to do so.

I just have a single partition unlike others with whom this problem usually exists. I read that this might be due to improper shutdown, but how many ever times i reboot, still i am not getting the option.

Any idea as to how i can get this back to normal functioning ?

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 128.0 GB, 128035676160 bytes
240 heads, 63 sectors/track, 16539 cylinders, total 250069680 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x6e96820e

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1            2048   249436159   124717056    7  HPFS/NTFS/exFAT
/dev/sda2   *   249436160   250050559      307200    7  HPFS/NTFS/exFAT

Disk /dev/sdb: 1007 MB, 1007681536 bytes
9 heads, 8 sectors/track, 27335 cylinders, total 1968128 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xf2c7259d

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          32     1968127      984048    6  FAT16
ubuntu@ubuntu:~$ sudo -parted -l
Matching Defaults entries for ubuntu on this host:
    env_reset, mail_badpass,
    secure_path=/usr/local/sbin\:/usr/local/bin\:/usr/sbin\:/usr/bin\:/sbin\:/bin

User ubuntu may run the following commands on this host:
    (ALL : ALL) ALL
    (ALL) NOPASSWD: ALL
ubuntu@ubuntu:~$ ^C
ubuntu@ubuntu:~$
share|improve this question

1 Answer 1

I kind of had the same issue when I first tried to install Ubuntu. Originally my laptop came with Windows 8. After enabling legacy OS in the BIOS I was able to install Windows 7, but I installed in on the original Windows 8 partition structure, but when I tried to install Ubuntu, the option to install alongside Windows was not available. I tried Windows repair to see if maybe the boot structure was install incorrectly, reboot after reboot, tweaks left and right inside Windows, and the BIOS to try and allow Ubuntu to load side by side with Windows but nothing worked. I ended up having to re-install Windows 7 and wiping the entire HDD when I did it. Once the HDD was wiped and a fresh install of Windows 7 was loaded, Ubuntu showed the option to install along with windows.

My best guess as to why I had the issue was that with the original set up, UEFI (Unified Extensible Firmware Interface, along with the format did not allow for Ubuntu to accurately check for other OS's. Unfortunately I an not Ubuntu savvy enough to figure it out on my own.

I do hope that this helps a little.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.