Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

How to record any internal sound like mic in and speaker out from same PC running Ubuntu using Audacity or something else?

For example under Windows someone does like this: (i want to do the similar) In Windows Record internal sound

EDIT:

I installed pavucontrol but in record tab it does not show Monitor of <your soundcard>

enter image description here

share|improve this question
    
@Takkat: i followed the answer, but it does not work, cause in my EDIT you can see i do not have similar like in the ANSWER was showing. –  YumYumYum Feb 1 '13 at 7:52
    
@Takkat: YEs 1) i started Audacity 2) After that i started the pavucontrol but same. Record tab on Pavucontrol always shows like i have shown in my EDIT. –  YumYumYum Feb 1 '13 at 11:41
    
YES - it works doing something with Configuration tab. Thank you. Also strange the recording tab shows only when Audacity is in live Record mode. But not before idle mode. –  YumYumYum Feb 1 '13 at 12:20

2 Answers 2

up vote 10 down vote accepted

To define the recording source for any recording application we may install pavucontrol Install pavucontrol.

As soon as we record any audio stream the name of the recording application and the source from where it records will be shown in the Recording tab. We then may be able to change the source to Monitor of <your soundcard> to record the output of our soundcard:

enter image description here

We may have to choose another audio profile in addition. This can be done from the "Configuration"-tab of pavucontrol, e.g. a "Duplex" sound profile for output of the microphone to our local audio sink:

share|improve this answer

You may have to select Analog Stereo Input (unplugged) in PulseAudio Volume Control (pavucontrol), in order to make it work.

This was the only way I was able to record audio after trying everything else I could find on recording audio from the sound card. Unfortunately you can't listen to the output at the same time with this setting.

Also see screenshot:

enter image description here

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.