Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Here I asked How can I save settings when booting an ISO file from HARD DRIVE.

After trying different combinations around Sadi's solution, the only thing that has worked for me is to place the ext2 file called casper-rw in a FAT partition, not in the system ext4 partition (I haven't been able to boot if the file is not in the FAT partition); and the only parameter that I need to add to the usual menu entry in grub2's menu that already booted the iso-image is "persistent" (no reference to the FAT partition, but I ignore if 'boot=casper' makes reference to the casper-rw used for persistence). The menu entry is like this:

menuentry 'ISO Booting - Ubuntu-64bit.iso live' {  
  set isofile="/home/user/Desktop/ISO/Ubuntu-64bit.iso"  
  loopback loop (hd0,3)$isofile  
  linux (loop)/casper/vmlinuz boot=casper iso-scan/filename=$isofile bootkbd=es console-setup/layoutcode=es persistent noprompt noeject --  
  initrd (loop)/casper/initrd.lz  
}

The problem is that the the whole FAT partition that contains the casper-rw ext2 file becomes inaccessible; it can't be mounted because it's busy; it is displayed, together with the /cow filesystem as mounted in Nautilus, but I only see /cow as root in mount's output . I would like to find a solution without repartitioning.

Is that possible?

share|improve this question

2 Answers 2

Yes, like C.S.Cameron said, you can access the FAT partition by opening filesystem/cdrom as the root user. Another option is making a ext2, 3 or 4 partition. But, if you find this hard, just follow what C.S.Cameron said and follow the steps in the quote below.

You can access the fat partition by opening filesystem/cdrom as root.

Another option to the 4GB limited casper-rw file is to make an ext2, 3 or 4 partition labeled casper-rw. A partition labeled home-rw will work as a separate home partition.

share|improve this answer
    
Thank you too, Kamran. As I answered C.S.Cameron, I don't know what is the filesystem/cdrom. I explored the filesystem mounted on /cdrom, as root, but there's nothing in relation to the FAT partition. I am not enthusiastic about repartitioning the hard drive because I have bad_block problems in one, the FAT is very little and, last but not least, all this is in an appl with rEFIt and I don't know how I managed to do it but dual boot is working although there seems to be something unfinished to make the gpt and mbr info consistent.... (I dont know,...something like that) –  Robert Vila Feb 1 '13 at 4:23

EDIT:

For 12.04 & 12.10 you can access the FAT partition by opening filesystem/isodevice as root, when booting an iso with grub2.

Another option to the 4GB limited casper-rw file is to make an ext2, 3 or 4 partition labeled casper-rw. A partition labeled home-rw will work as a separate home partition.

share|improve this answer
    
What is the filesystem/cdrom?. After iso-booting with persistence, there is the /dev/loop0 filesystem already mounted on /cdrom but it doesn't seem to have anything to do with the FAT partition with the casper-rw file. The problem with the solution I am using is that it doesn't let me access the other files I have in the FAT partition and that I need to use and to be there to be accessible from to the MacOS that shares the hard drive. Good to know about the second point, Thanks. –  Robert Vila Feb 1 '13 at 4:25
    
Why are you repeating what Kamran Macey writes?. I don't understand what does "you can access the FAT partition by opening filesystem/isodevice as root, " mean –  Robert Vila Feb 4 '13 at 13:13
    
If you open Nautilus, click on "filesystem" then click on the folder "isodevice", you should see the contents of your FAT partition. –  C.S.Cameron Feb 5 '13 at 1:27
    
Why do you say that? No. It is the linux ext4 partition, where the ISO image used to boot is saved, which is mounted on /isodevice. I am not booting from a file in a FAT partition. As I said the casper-rw is o the root directory of a FAT partition, and the whole FAT partition is unaccesible, except for the casper-rw used for persistence. –  Robert Vila Feb 8 '13 at 1:02
    
Sorry, I thought the iso file was located in the FAT32 partition. How about putting the iso file there, then the above should work. –  C.S.Cameron Feb 8 '13 at 1:58

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.