Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to turn off animation of windows appearing and disappearing when switching between Compiz viewports. I've tried to turn this animation off by the setting-changes listed in a bullet list below. However, windows still seem to slide or zoom out of the old viewport or into the new viewport whenever I switch viewports, rather than popping instantaneously into place like I want. Here is the script I used to test the behavior:

#!/bin/sh
S=1.5; W=1680; H=1050

for y in 2 1 0; do
    for x in 2 1 0; do
    wmctrl -o $(($x*$W)),$(($y*$H))
    sleep $S
  done
done

Note, I installed wmctrl via sudo apt-get install wmctrl. The command line
wmctrl -m; echo $DESKTOP_SESSION; echo $XDG_CURRENT_DESKTOP; cat /etc/issue.net; cat /proc/version;uname -a
on my i3-2120 CPU @ 3.30GHz system displays the following.

Name: Compiz
Class: N/A
PID: N/A
Window manager's "showing the desktop" mode: OFF
ubuntu
Unity
Ubuntu 12.04.1 LTS
Linux version 3.2.0-36-generic (buildd@allspice) (gcc version 4.6.3 (Ubuntu/Linaro 4.6.3-1ubuntu5) ) #57-Ubuntu SMP Tue Jan 8 21:44:52 UTC 2013
Linux biti 3.2.0-36-generic #57-Ubuntu SMP Tue Jan 8 21:44:52 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Here are the setting changes made in my attempts to fix the problem. (Note, several of these settings probably are irrelevant, but I haven't found a discussion that explains which, if any, are relevant to the current problem.) (Note, CCSM stands for Compiz config-settings-manager, which I installed with
sudo apt-get install compizconfig-settings-manager)

• On CCSM/Effects, unchecked the Fading Windows and Animations boxes.
• On CCSM/Desktop/Desktop Wall, set target preview visibility time to zero.
• Also unchecked Show viewport switcher preview and Show live viewport previews.
• In CCSM with expo in search box, clicked expo, and on Behaviour tab set zoom time to 0.1 (it won't go to less) and checked Immediate moves.
• Set Expo animation to Zoom (there is no animation-off option on the tab)

Summary of question: How do I turn off animation of windows appearing and disappearing when switching between Compiz viewports, and make those windows just appear as quickly as possible?

share|improve this question
add comment

1 Answer

A previous question, Turning off the transition animation when changing workspaces in GNOME2, has an answer that partly solves the problem.

First, install ccsm (the CompizConfig settings manager) if it isn't present, either via Ubuntu Software Center or with apt-get:
sudo apt-get install compizconfig-settings-manager
Next, run ccsm, and click Desktop, Desktop Wall, and Viewport switching in turn. Set Wall sliding duration to 0. (On my Ubuntu 13.04/Unity/Compiz system, that duration defaulted to 300 ms.)

This still leaves the following problem that occurs when I run the test script shown in the question. When wmctrl issues a command to switch to a different viewport, that viewport is immediately displayed (as desired) but also a scaled-down viewport-indicator box animation appears. In a fraction of a second that box shrinks and disappears.

To deal with that issue, in ccsm click Desktop, Desktop Wall, and Viewport switch preview in turn. Change Switch target preview visibility time from 0.2 to 0. After that the test script runs cleanly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.