Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm on an Thinkpad x220, Ubuntu 12.10, kernel 3.5.0.22, recently updated BIOS (1.37) : today out of nowhere, my computer shuts down immediately when I unplug it, even though the battery is present, recognized and charged.

It won't go beyond 66% charged though. In power statistics, the battery is recognized as having a 37.2wh charge and as being healthy. The 'time to full value' however, is 0.

Power statistics:   
Device: battery_BATO Technology: Lithium Ion 
Vendor: LGC Model: 42T4865 Serial number: 10189 Present: yes Rechargeable: yes
State: charging  Voltage: 11.9 V  Energy: 37.2 Wh  Energy (design) 62.2 Wh   
Percentage: 66.2% Capacity: 90.4% Time to full: 0 seconds Time to empty: 0 seconds

I have tried unplugging the battery, reboot, replugging the battery, reboot as described in the answer here:

and I have tried adjusting the settings of dconf Editor (In org > gnome > settings-daemon > plugins > power I changed the value of critical-battery-action to nothing. I have also unchecked the option notify-perhaps-recall), as described here:

Tried installing tp_smapi, as described here: when opening stop_charge_thresh,in /sys/devices/platform/smapi/BAT0 (there is also a folder for BAT1), I saw that the threshold for stopping charging was 100. When opening start_charge_thresh , I am unable to open the file. In terminal I get this error:

 (gedit:3617): WARNING **: Hit unhandled case 0 (Error reading from file: No such device or address) in parse_error.

all to no avail, unfortunately.

Is this a broken battery? Or something else? How can I find out?

UPDATE: the battery no longer shows in the system tray. I can however still find its specs and status with: upower -i /org/freedesktop/UPower/devices/battery_BAT0

Thank you

share|improve this question

closed as off topic by gertvdijk, Jorge Castro, Tom Brossman, belacqua, Eric Carvalho Feb 2 '13 at 0:44

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
What laptop is this concerned? Did you install the latest BIOS update? Does your OEM manufacturer provide a tool to re-calibrate your battery? To me this seems like a confused power controller (hardware, embedded), unrelated to Ubuntu. However, it could be a bug as well - do you run another OS as well by chance? –  gertvdijk Jan 31 '13 at 18:48
    
Please post all of the battery statistics. Of particular interest is the voltage, design voltage, and design capacity. –  psusi Jan 31 '13 at 18:57
1  
Please edit your question to provide the additional information. This is a Q&A site, not a discussion forum and comments are not fit for this. –  gertvdijk Jan 31 '13 at 19:20
1  
@Peeperkorn "my computer shuts down immediately when I unplug it" Do you mean it's an instant-off (unclean) or a graceful shutdown? In the first case, I believe this is a hardware issue. The power to the system should still be active on non-ACPI aware operating systems when you unplug the power cord. To clarify just boot into the System BIOS configuration and unplug the power cord. If that still instant-powers-off the system: go and RMA the laptop or battery. –  gertvdijk Feb 1 '13 at 10:26
1  
@Peeperkorn Please contact Lenovo services. This is a hardware issue, clearly. I'm sure they'll be able to help you out by pointing out what just became clear. I'm voting-to-close this question for the reason being unrelated to Ubuntu and therefore off-topic. –  gertvdijk Feb 1 '13 at 14:19
show 3 more comments

Browse other questions tagged or ask your own question.