Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The last access timestamp of my files is updated every 24 hours whenever I access an files. E.g. I type "ls" and if the last access timestamp of the file is older than 24 it is updated to the current date.

Has anyone else the same phenomenon and any idea what is causing it. I have a SSD, perhaps it is related to this.

share|improve this question
1  
Do you have an indexer running that indexes all your files for faster searching? I believe the default Ubuntu installation does this. (Not running Unity, so can't really provide an answer) –  gertvdijk Jan 31 '13 at 18:42
2  
updatedb (from mlocate, installed by default) runs daily. Try either temporarily removing it or disabling /etc/cron.daily/mlocate. –  Andrea Corbellini Jan 31 '13 at 18:46
3  
@AndreaCorbellini updatedb would only update directory timestamps, never timestamps on regular files, since it only indexes file names and not file content. –  Gilles Jan 31 '13 at 19:13
    
@Gilles: you're right. Sorry! –  Andrea Corbellini Jan 31 '13 at 21:13
    
Does this still happens? –  Braiam Jan 17 at 16:10

1 Answer 1

If you have a SSD, the relatime mount option is automatically set. Here is what it does (source):

Relatime maintains atime data, but not for each time that a file is accessed. With this option enabled, atime data is written to the disk only if the file has been modified since the atime data was last updated (mtime), or if the file was last accessed more than a certain length of time ago (by default, one day).

Try changing relatime to noatime in your /etc/fstab file to confirm the reason for these updates.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.