Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm installing Ubuntu 12.10 from USB and everything went fine, but on restart it opens the installation files, bacause the USB is there and if a remove it, the laptop acts if there is no OS installed. How to make it to detect that Ubuntu is actually there? When to remove the USB? Please help :( Thanks in advance! :)

share|improve this question
    
Did your PC come with Windows 8 installed? –  Drake Clarris Jan 31 '13 at 20:35

1 Answer 1

up vote 3 down vote accepted

It's supposed to tell you explicitly when to remove the USB flash drive, but I think that, unfortunately, that message is not visible 100% of the time.

It's right when the live system shuts down. The best time to remove it is before rebooting. If you've rebooted already and you're in the live system again, then shut down, remove the USB flash drive, and boot your computer.

Assuming there were no problems during the installation, Ubuntu should be installed and working.

If It Still Doesn't Work

If the installation appeared to complete, but booting without the flash drive fails without detecting an operating system, this usually means the GRUB2 boot loader did not successfully install to the Master Boot Record. To fix this, boot from the USB flash drive, select Try Ubuntu (not Install Ubuntu), and reinstall GRUB to the MBR, using any of the techniques on either of these pages:

If It Still Doesn't Work

Then it's necessary to collect more information to troubleshoot the problem. Boot from the USB flash drive, select Try Ubuntu, open a Terminal window by pressing Ctrl+Alt+T. Run:

sudo parted -l

Then select the text from the terminal, copy it to the clipboard, edit your question (or, for readers besides the creator of this question, ask a new question) and paste the text in. You can format it with the <$> tool in the Ask Ubuntu editing toolbar.

share|improve this answer
    
Thank you! :) I couln't see any message :( –  Faery Jan 31 '13 at 16:40
    
The problem is still there :( I reinstalled it and it's the same again - if there is no USB - no OS detected, only BIOS, if it is there - the installation begins. :( –  Faery Jan 31 '13 at 17:43
    
@Faery I've expanded my answer--hopefully this will help. –  Eliah Kagan Jan 31 '13 at 19:30
    
Thank you very much! :) –  Faery Jan 31 '13 at 19:33

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.