Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My laptop CPUs are throttled down to .8GHz instead of 2.5GHz whenever I am connected to AC only and not the battery. I tried using cpufreq-set and it allows me to set the speed when the battery is connected but it stays at a maximum of .8GHz when the battery is disconnected. Is there a way to prevent this?

Update: I've also tried changing the governor, but it seems locked at .8GHz whenever it's on only AC power. Are there any overrides for this?

share|improve this question
    
This will solve all your problem ... use powersave on ac/bat askubuntu.com/questions/285434/… –  Qasim May 16 '13 at 12:27
    
@Qasim That looks like a great tool and I'm liking it already, but sudo tlp ac still has the CPUs at .8GHz if I take out the battery. Could this be a BIOS or kernel issue? –  Vreality May 17 '13 at 9:34
    
.8 mean running on 800 MHz & thats 100 % fine ...you can change it with cpu freq indication ...see just after TLP settings ...you don’t need to > sudo tlp ac < , removing battery ...that i would say dont do that ...cauzz if ac power is disconnected you have change of data corruption ...talking the battery out and running on ac power no issue ... i have done several time no issue ...but its dangerous .. –  Qasim May 17 '13 at 9:56
    
@Qasim I don't really understand the beginning of your comment, but it works fine on AC only (not battery); it's just slow. The point is, I want to be able to run CPU intensive programs on only AC power so that I don't mess up my battery. I'm okay with the data loss risk; power outages/resets are rare where I live. –  Vreality May 17 '13 at 10:22
    
use 3.) Processor and Frequency Scaling > ondemand < on both ac/bat .. –  Qasim May 17 '13 at 10:33
show 4 more comments

1 Answer 1

up vote 1 down vote accepted

CPU scaling is controlled by your BIOS and not by the software running on the computer.

Reboot and go into the BIOS configuration.

Look for an item called "CPU scaling" and toggle it.

If it's not there, you can't prevent that from happening.

share|improve this answer
    
Thank you! This makes sense, but I don't think my BIOS has that option... Do you know why the BIOS has this option? –  Vreality Aug 27 '13 at 12:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.