Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First off, I am fairly new to Ubuntu. Anyway.

I very recently bought a laptop that comes with a FreeDOS, and a disk containing drivers.

Installation of Ubuntu was fine. However, I think many important drivers are not installed. For example, I can't even connect to wifi, it detects nothing. When I also looked up the "graphics" of my laptop, it says unknown, although it has AMD Radeon HD 7670M.

Then I tried to use the disk that supposedly contains the drivers. However it does not work, and when I try to manually run the "CDsetup.exe", a window appears where it seems to be reading the .exe file as an archive, then an error message appears(I can't really paste the error message here, I am only using my phone which is my only way to the internet right now.:()

I think the laptop salesman told me that the disk works only(?) for windows, and true enough, there's a "windows7" folder in the disk. He wasn't sure if the disk works for Ubuntu.

Do you think that's the problem? And if so, how do I install the drivers when I can't even connect to the net?

Advanced thanks to anyone who answers!!! Your help is GREATLY appreciated.:)

Edit:

Here are the results of what Mr. Web-E told me to type in the terminal.

When I type "lspci":

00:00.0 Host bridge: Intel Corporation Ivy Bridge DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Ivy Bridge PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation Ivy Bridge Graphics Controller (rev 09)
00:14.0 USB controller: Intel Corporation Panther Point USB xHCI Host Controller (rev 04)
00:16.0 Communication controller: Intel Corporation Panther Point MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation Panther Point High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 1 (rev c4)
00:1c.3 PCI bridge: Intel Corporation Panther Point PCI Express Root Port 4 (rev c4)
00:1d.0 USB controller: Intel Corporation Panther Point USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Panther Point LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation Panther Point 6 port SATA Controller [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation Panther Point SMBus Controller (rev 04)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT/GL [Radeon HD 7600M Series]
02:00.0 Network controller: Atheros Communications Inc. Device 0037 (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)

When I typed "sudo lshw -c network": soren@soren-CX41-1AC:~$ sudo lshw -c network

 *-network UNCLAIMED     
       description: Network controller
       product: Atheros Communications Inc.
       vendor: Atheros Communications Inc.
       physical id: 0
       bus info: pci@0000:02:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:f7c00000-f7c7ffff memory:f7c80000-f7c8ffff
  *-network
       description: Ethernet interface
       product: RTL8111/8168B PCI Express Gigabit Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: eth0
       version: 06
       serial: 8c:89:a5:03:d8:97
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl8168e-3_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:43 ioport:d000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff

When I typed "rfkill list all" Nothing happens. :(

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Welcome to askubuntu. Please don't ask many question in one question. For graphics card issue create a question, for wireless another. Please try to follow it next time. :)

Answers;

My gpu isn't detected,

Follow How can I get my graphics card to be recognized in System Info?

Drivers

Yes,Windows driver aren't compatible with linux.

But good news, almost all drivers are built in ubuntu. But few companies don't want to give away source code of their driver, so these are propitiatory drivers and need to be installed separately.

With internet there is a great way to get such restricted drivers, press Windows key (key between alt and ctrl on left side), search for addtional drivers. This will fetch the drivers required for your laptop.

Please check whether by any means you can connect to internet using wired neteork/ usb modem.

If you can connect,

graphics card driver installation instruction - follow this

What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

Without internet, it is a bit difficult,

For wireless driver we need the hardware id, or you can search using that id in this forum.

To get hardware ids, open a terminal, execute these commands one by one. Copy the result and add to your question

lspci

sudo lshw -c network

rfkill list all


Update:

Your wireless card isn't at all recognized by ubuntu. :( . I think this is a newer model.

If you can install\test ubuntu 12.10 that will be better. You don't have to install anything (hopefully). Atheros driver free, as your model is new one. It doesn't include the drivers.

If you can connect by any other means (ethernet/usb modem)

execute following

sudo apt-get install linux-backports-modules-cw-3.6-precise-generic

Last resort will be building driver as told here Atheros wifi not working 12 LTS

share|improve this answer
    
oops, my bad.xD But actually my question is about installing drivers in general. See, it was a freeDOS laptop, so I thought there were totally no drivers, including USB(2.0 and 3.0), Bluetooth drivers, etc. I thought I have to install every driver on Ubuntu to make my laptop, well, "work". But I just narrowed it down to two in particular, the wifi and the GPU, so that it will not be a very long question. But as you said, many drivers are already in Ubuntu. So, does that mean that I don't really need the disk(that contains the drivers) that they provided me? –  Soren Feb 1 '13 at 3:03
    
But I am yet to try what you told me(I am in school), so I will just tell what happens... –  Soren Feb 1 '13 at 3:07
    
If you use ubuntu, you don't need the disk. Use windows, yes you need the disk. Don't go for ndiswrapper it is the last resort for vary rare drivers and old method too. Now a days almost all wi-fi driver is out for ubuntu. You just need to search, if you don't understand. Please post the result of the commands I said in my question. –  Web-E Feb 1 '13 at 3:49
    
Oops sorry I am still new to this site, didn't know there was a character limit.xD I will just "add" it to my question.:) –  Soren Feb 1 '13 at 14:30
    
It works now!!! All I did was install the Linux-backports-modules-cw-3.6-precise-generic using the "dpkg" command. I downloaded all of them from ubuntuupdates.org. I said "all of them" because when I first tried to install it, it said that it needed a previous version of itself to install, and that in turn needed something like a Linux image something(I don't really know what it really is but it worked anyway). Long story short all I did was to carefully read the error messages in the terminal, and download the necessary versions on my phone. –  Soren Feb 2 '13 at 6:53

First, welcome to Ubuntu...

Know your basics first... Ubuntu is one of many Linux versions or 'distributions'. Of course it's one of the most popular.

Windows on the other hand is a product from Microsoft. Now, if you see any program that has and extension "exe" or "dll", it is guaranteed to be a Windows-only product. So the first thing you should do is to see in your CD, if there are any folders named "Linux" or "Ubuntu" or even "Debian". If you don't find any, then your CD is strictly Windows-only. So you shouldn't waste time trying to get it going.

Now, assuming that you don't have a CD for Linux/Ubuntu, the best way to install all drivers is to first install the OS with a network cable connected to your computer so that it detects that networking/internet devices automatically.

Of course you can install all this later on and configure your wireless connection later but as a person new to Ubuntu or Linux in general, that would mean a very lot of work. So if this is a fresh intallation, you're better off redoing it. But make sure that you're plugged in to the net via a cable.

If on the other hand, you're up for a challenge, you may try looking for answers on how to configure networking for Ubuntu.

share|improve this answer
    
Aww, too bad. No, there weren't any .deb files in the disk, only .exe's and .dll's. :( But some sources say that I can install wifi drivers using ndiswrapper.... what do you say about that? I am actually up to the challenge, so yeah, thanks!!! –  Soren Feb 1 '13 at 3:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.