Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am perfectly able to set primary monitor via Nvidia X Server Settings or displays settings. It works just fine for the most of my needs.

Except for one. System ignores these settings when I want to save a file to my desktop. It always saves new files to my left hand side desktop, although my primary monitor is on my right hand side.

This is very annoying since I want to use my left display only for browser window, which I always keep open while on the right desktop I do all my other stuff like programming, browsing files, writing documents etc..

So how can I set my primary desktop to the same value as my primary display?

EDIT: I have tried to switch the cables, displays but either one doesn't solve the problem. System always use left hand side desktop as a primary.

share|improve this question

1 Answer 1

  1. The primary monitor is the monitor that gets used when you boot, so it's a setting you have to change in your BIOS. Ubuntu allows you to move screens around so that your secondary monitor can be placed anywhere you want it, but it stays the secondary monitor.

If your BIOS doesn't allow you to do this (my Siemens laptop allows this, my IBM doesn't) I can give you something to try, but at the moment, I don't have a secondary monitor to test this, so I cannot vouch for it (I'm travelling).

  1. Only works on a powered-down laptop: close the lid, turn on computer, hope that the secondary monitor shows the boot screen now. (if your on-button is not on the side of your machine: test how far you have to close the lid for the monitor to shut itself off while you're reading this and the laptop is still on)

  2. The next one is grasping at straws, not for the faint-at-heart but it might just work.

    • Make a full system backup (I use clonezilla)
    • Create a secondary user and log in there if this goes horribly wrong and none of your monitors work any more.
    • gedit ~/.config/monitors.xml
    • cut the primary monitor section between "" and paste it below the secondary monitor.
    • log out
    • pray
    • log back in

]:-)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.