Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have now spend several evenings searching this forum for an answer on how to get the internal card reader on my desktop working. It does not show up in any of the lists that terminal commands have produced and the various 'fixes' that I have been able to attempt have not worked. A list of supported card readers has not been located, so purchasing an alternative may not work. The Alcor data sheet for AU6371 B51-JDL-GR indicates that it should work without an external driver, but does not mention Linux.

Is there a solution?

Sorry for slow response to the assistance, I got locked out and had to have my account recovered!

I tried putting an SD 128MB card into the reader prior to boot, but not visible in Home Folder (Nautilus?). I also tried an SDHC 32GB with the same result.

Input-utils is installed Medibuntu is a listed source

Tried alternative usb connectors on the ASUS motherboard, with no effect.

Have used Terminal to run modprobe sg, modprobe sd_mod, modprobe usb_storage and modprobe scsi_mod with no effect noticed or reported.

sg_scan -i in terminal gave, sg_scan: Error opening /dev/sg0 : Permission denied /dev/sg1: scsi2 channel=0 id=0 lun=0 [em] PIONEER DVD-RW DVR-217F 1.07 [rmb=1 cmdq=0 pqual=0 pdev=0x5]

lsusb and lspci in Terminal do not list the internal card reader, or anything that might be it.

I have also found 'Getting Started with Ubuntu 12.10', but that has not indicated what to try next.

I have also found vendors with card readers based on the Alcor AU6370 that they advertise as Linux compatible, but I have doubts.

Advise please.

share|improve this question
    
Welcome to Ask Ubuntu! Please be more specific about what you've tried, what the terminal commands output was, etc. It would be sad if we ask to provide the same information you already got there and likewise for answers with steps you already took. Also, include more hardware information. Include at least the output of lsusb and lspci -nnk | grep -iEA3 "(SD Host|MMC|card read|alcor)" in your question. –  gertvdijk Jan 30 '13 at 23:06
    
roger@roger-desktop:~$ lspci -nnk | grep -iEA3 "(SD Host|MMC|card read|alcor)" roger@roger-desktop:~$ –  user127403 Feb 1 '13 at 22:04
    
The above is a copy of what Terminal showed when I input the above requested 'code'. To me it seems that it was ignored, or that I have incorrectly input. –  user127403 Feb 1 '13 at 22:07
    
Now that you say it's a USB device, please give the complete output of lsusb. It may not be listed with a name you recognize as being a card reader, but the numerical IDs might reveal it. I'm skilled at that. So please post the output of it rather than telling it does not list it. –  gertvdijk Feb 1 '13 at 22:12
    
roger@roger-desktop:~$ lsusb Bus 001 Device 002: ID 050d:705c Belkin Components F5D7050 Wireless G Adapter v4000 [Zydas ZD1211B] Bus 003 Device 002: ID 046d:c045 Logitech, Inc. Optical Mouse Bus 004 Device 002: ID 0d62:0004 Darfon Electronics Corp. Keyboard Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub roger@roger-desktop:~$ –  user127403 Feb 1 '13 at 22:20

2 Answers 2

The above analysis that it was a hardware problem proved to be correct. Thank you for your patience with me.

I replaced the original 3.5" multi-card reader with a Pluscom branded one and both SD and SDHC cards are now accessible as intended. I do not have other types of card to try. The controller is an Alcor AU6477.

share|improve this answer

If you can't find a way to get it to work I recommend trying to get an alternative even though you think it won't work.. But most card readers problems I've read about are related to this but I googled card readers for linux to find you some you could purchase if you don't find a way and couldn't really find anything for you. I recommend to find some commands, google it a bit more, and if that doesn't work then.. :(

share|improve this answer
    
Getting an alternative card reader seems like an admission that the logic of Linux coding is not understood. If we have the ability to get some internal card readers to work, why can we not get them all working? –  user127403 Feb 1 '13 at 22:18
    
gertvdijk, Please also see this Terminal information,roger@roger-desktop:~$ sg_map -i Error opening /dev/sg0 : Permission denied Error opening /dev/sda : Permission denied /dev/sg0 some error /dev/sg1 /dev/sr0 PIONEER DVD-RW DVR-217F 1.07 roger@roger-desktop:~$ –  user127403 Feb 1 '13 at 22:40

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.