Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to remove the GNOME panel completely. I spend most of my time in a (tmux) terminal or a browser. Synapse and a small hidden AWN panel fit the rest of my needs.

I have tried all recommended solutions including this (found it a few places):

However it always comes back at log in. I have tried changing the required components > panel to avant-whatever as well as to empty. I have tried setting them both as default (right click set as default).

Right now I just have the last panel set to transparent and auto hide, but it still tends to be annoying.

What do I need to do to get rid of this damn thing?

Clarification:

Using gconf-editor, gconftool2, and/or Ubuntu tweak to set /desktop/gnome/session/required_component/panel to avant-window-navigator is not working. The setting stays when I reboot, but the empty gnome panel sticks around.

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

There's an explanation of how to replace gnome-panel with awn on the AWN FAQ

If you have "Configuration Editor" (AKA gconf-editor) installed, run it and navigate to the key folder /desktop/gnome/session/required_components. Double-click on the key panel in the right-hand pane to edit it, and change the value to "avant-window-navigator" followed by the "OK" button. Alternatively, you can run the following command from the terminal:

gconftool-2 --type=string --set /desktop/gnome/session/required_components/panel 'avant-window-navigator'

I did this on my laptop the other day and it worked fine. As a side note, to bring gnome-panel back:

gconftool-2 --type=string --set /desktop/gnome/session/required_components/panel 'gnome-panel'
share|improve this answer
    
This is the way everybody recommends. I have used this method perfectly on my laptop. However my desktop has one panel that defies removal. –  Alan Peabody Feb 6 '11 at 4:51
    
@alan-peabody That's strange. That means that gnome-panel must still be running. What happens when you run ` ps -A | grep panel` in the console? I haven't tried this, but maybe you could find and remove the panel from ~/.gnome/apps/panel/toplevels (I'd probably back that directory up first before messing with it). Also, is it possible that that extra panel is the wingpanel app or something? I know when I installed it, it looked like some misc. empty panel. –  enobrev Feb 6 '11 at 13:16
    
ps -A lists: 2193 ? 00:00:00 gnome-panel The directory you mentioned does not exist. I do have a ~/.gnome2/panel2.d/ directory. I have not installed wingpanel, although the original mock up certainly was appealing. –  Alan Peabody Feb 8 '11 at 0:10
    
Actually I DID have wingpanel installed (dunno what late night I did that...). Removing it solved the problem. Thanks! –  Alan Peabody Feb 8 '11 at 0:19
    
@alan-peabody You might still want to find out why gnome-panel is running if you've explicitly told gnome not to start it. Otherwise I'm glad you got it working! –  enobrev Feb 8 '11 at 0:44
add comment

I failed completely to disable the GNOME Panel in the standard GNOME sessions on Precise (12.04). But I tried this script and it worked for me, adding a new session option on the LightDM login screen.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.