Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been trying to get pam_mount to mount a tmpfs drive for domain users, so that it is volatile storage and is cleared on every logout. The problem I found was that although the area would mount fine, it wouldn't unmount again. Checking in auth.log showed me that the umount command was saying Device is busy.

So I tried to manually unmount the device (the user is logged out at this stage) but the error was still persisting. However, lsof and fuser showed no files opened within the area. Looking at some other related problems I also tried losetup to find any loopback devices, but there were none. The exact mount command I used was:

mount -t tmpfs -o uid=1001,gid=1001,size=100m,mode=0700 none /home/user

To cut a long story short, I have narrowed the cause down to something in X, the X session, XFCE, LightDM login, or any other graphical apps. The problem does not manifest itself with virtual terminal logins, or if I don't log in at all. Unmounting only gives the error if I log in through the graphical login.

And just to make it even more confusing, I tried the same test on my home Arch system which also runs XFCE. This time it worked flawlessly.

System specs: Ubuntu 12.04, XFCE desktop, LightDM with KDE greeter, winbind authentication.

share|improve this question
    
Welcome to Ask Ubuntu! Can you include some more specific information? For example the output of grep home /proc/mounts and dmesg | tail during these times you try to unmount it. I believe you might be hitting a GVFS "feature" here. –  gertvdijk Jan 30 '13 at 23:28
    
Pastebin dump shows the stages of mounting/unmounting. dmesg just shows some CIFS errors, but this problem occurs even without mounting CIFS shares inside the home area. I have already uninstalled GVFS prior to this question, since I thought it might have something to do with it. –  Xenopathic Jan 31 '13 at 11:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.