Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Poppler 0.20.4 isn't able to render specific pdf files the right way. How can I upgrade libpoppler to the newest version?

I use Xubuntu 12.10 and tried to open the pdf with evince zathura an so on . None of them could open the file. So I think the problem is the libpoppler. But how can I patch it?

share|improve this question
    
no one ? no chance to open the pdf ? –  user127375 Feb 13 '13 at 15:42
add comment

1 Answer

You have the option to build it from source. You may download the latest poppler version from the official website. At the time of writing, this is Poppler 0.22.3.

Then you would build and install it:

./configure --prefix=/usr \
    --sysconfdir=/etc \
    --disable-static  \
    --enable-xpdf-header
make
sudo make install

I have successfully tested this with Ubuntu 13.04. From there on, you can also upgrade zathura if you want to, by building the latest zathura and zathura-pdf-poppler-plugin. The latest zathura version in the repositories is over a year old so that might be of interest for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.