Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently reformatted my laptop to run Ubuntu 12.04. I purchased the laptop new in New Zealand (default: region 4 dvd) and it came with Windows XP. I had no trouble watching local region 4 dvd's on the laptop under Windows. Now, with Ubuntu region 4 dvd's wont play. The error message says that the dvd's might be "encrypted". I can see the AUDIO_TS and VIDEO_TS folders, but Movie Player, VLC, and xine wont recognise the content.

Also, I checked and libdvdread4 is already installed.

Any suggestions?

Thanks

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

It is not enough that "libdvdread4" just be installed. It must be activated/executed. If you have not executed the file yet, this could be the cause of your problem.

Do the following to execute the file:

1) confirm that "libdvdread4" is installed

2) open Nautilus and navigate to the following menu entry: Edit > Preferences > Behavior

3) under "Executable Text Files" enable "Run executable text files when they are opened" and then close the window

4) press Alt+F2 and type "gksu nautilus" and enter your password when asked

5) in the window that opens navigate to: /usr/share/doc/libdvdread4

6) double-click the file "install-css.sh" and then close the Nautilus-root window

7) in a non-root-Nautilus window, return to: Edit > Preferences > Behavior

8) under "Executable Text Files" enable "Ask each time" and then close the window

DVDs should now be playable with VLC. Playing with Totem is hit or miss in my experience.

share|improve this answer
    
Greg, that worked perfectly! Thanks for the instructions.. I would have never figured that out. Seems strange that the DVD reading library wouldn't work by default. Thanks! –  Hairysun Jan 31 '13 at 7:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.