Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to install Ubuntu 12.04, but when during the installation I face some difficulty regarding the step in which Ubuntu tries to take a picture using the webcam.

There is a window, when Ubuntu tries to take a picture and at that point the installation is interrupted. Should I look for a proper webcam driver? Or, should I find a way to disable the camera so that I prevent this step?

I'm using old Asus A8JN with a Core Duo T2300E, 2.5 GB memory and a 160 GB HDD.

I think that camera is "YaHsin Chicony" but i'm not sure.


Bus 001 Device 003: ID 0ac8:0321 Z-Star Microelectronics Corp.
Vimicro generic vc0321 Camera
Bus 001 Device 004: ID 03f0:5307 Hewlett-Packard
Bus 003 Device 002: ID 0b05:1712 ASUSTek Computer, Inc. BT-183 Bluetooth 2.0+EDR adapter

and there is a line from usb-devices | grep Driver:

I:  If#= 0 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=00 Prot=00 Driver=vc032x
share|improve this question
Welcome to Ask Ubuntu! This sounds like a bug, but of course there's a way to work around and disable this. We'll need more hardware information for that. Can you run from a live CD, "Try Ubuntu" and provide the output of lsusb run from a terminal? Also, the output of usb-devices | grep Driver should show one of the webcam drivers (e.g. uvcvideo). Do this by editing your question. I can provide an answer on how to disable this during installation then. – gertvdijk Jan 30 '13 at 18:45
helped command: sudo rmmod gspca_vc032x here is little more about the problem link – Cortes Jan 30 '13 at 19:31

Below are steps to disable the kernel module (driver) for your webcam (gspca_vc032x), temporarily, using the initial boot menu of the Ubuntu Live image. It basically is just using the kernel boot parameter modprobe.blacklist=gspca_vc032x to do so.

  1. In the initial boot menu when booting the live image, press any key to enable the menu.
  2. Select your language; I chose English here.
  3. Highlight the option you want to continue using later (e.g. Try Ubuntu without installing). Don't start yet!
  4. Press F6 (Other Options)
  5. Press Esc to escape from this menu and start a custom editor of the kernel boot parameter line.
  6. The cursor should be at the end of the line now ending with --. Remove the two dashes.
  7. Type modprobe.blacklist=gspca_vc032x
  8. Press Enter ↵ to boot.

enter image description here

Alternatively, you can disable the kernel module after you booted as well.

  1. Boot Ubuntu (live image) the regular way.
  2. Before starting the installation, open a terminal.

    • Use the regular Terminal application Ctrl+Alt+T, or,
    • A virtual terminal, by pressing Ctrl+Alt+F1. Log in using username ubuntu and no password.
  3. Unload the kernel module to effectively disable the camera:

    sudo rmmod gspca_vc032x
  4. Close the terminal application, or, if you used the virtual terminal, go back to the graphical screen using Ctrl+Alt+F7.

  5. Continue as usual, starting the installation.
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.