Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

On my dual boot laptop I noticed that maximum brightness in Ubuntu and Windows 8 is totally different. In Windows 8 the screen is much much brighter at maximum level than it is at Ubuntu maximum level. (I was even asked why my laptop display looks that dim.)

I have a Lenovo ThinkPad E330 Laptop with Intel HD 4000 graphics.

How can I increase the maximum brightness level Ubuntu uses?

share|improve this question
    
Same Issue. Even though I don't have dual boot, I've always felt my display to be dim. –  TheKojuEffect Jan 30 '13 at 17:37
    
I'll try to take some pictures to show the difference as I think screenshots don't make any sense here. –  joschi Jan 30 '13 at 17:40
    
Added the information. To give a little update to the described problem: I failed in making some photos, that could show the effect so it's just a subjective impression I have when I look at Ubuntu or Windows. I guess brightness is controlled by the kernel and there's no setting maximum brightness higher than maximum brightness because it's determined by the hardware, or am I wrong? –  joschi May 14 '13 at 8:44
    
try this app , may be it will help you omgubuntu.co.uk/2013/04/brightness-control-ubuntu –  Qasim May 14 '13 at 8:56
1  
The mentioned app (brightness control indicator) is just using the system values for brightness and doesn't allow you to increase brightness to a higher value than that. –  joschi May 14 '13 at 10:13
show 1 more comment

3 Answers

Ubuntu has a preset range of values that it can give to any hardware device and assumes that they all use the same brightness values (which they don't) because the BIOS controls for Ubuntu are poorly coded.

The control is integrated into the window manager and can't be individually configured (same goes for the brightness OSD which can't be disabled without disabling power management altogether).

I filed a bug for this years ago.

This is a known issue and has been for several years. Canonical doesn't care because fixing your brightness wouldn't generate any revenue. They are too busy focusing on integrating Amazon referrals into their window manager.

share|improve this answer
add comment

This worked for me, you could give it a try:

  1. $ sudo gedit /etc/default/grub

  2. Replace this line GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" with
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

  3. Save and close

  4. $ sudo update-grub

  5. reboot

share|improve this answer
add comment

did you try xrandr I had the opposite of your problem, my monitor was too bright and adjusted it using xrandr

xrandr --output VGA1 --gamma 0.7:0.7:0.7 --brightness 0.8

you need to replace VGA1 with your current output, and replace 0.8 and 0.7 by 1.5 for example. by default they are all set to 1.

I hope this helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.