Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would have expected System ▸ Administration ▸ Login Screen ▸ Play login sound to control this, but unchecking it does not prevent the drum beat sound from playing.

share|improve this question

15 Answers 15

up vote 29 down vote accepted

For 12.04 and 13.04 (LightDM)

unity-greeter versions prior to 0.2.8-0ubuntu1 has no way to disable the lightdm start-up sound. This has been addressed here.

For unity-greeter version 0.2.8-0ubuntu1 and up, start-up sound can be disabled via:

sudo sh -c "echo '[com.canonical.unity-greeter]' >> /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override; echo 'play-ready-sound = false' >> /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override"
sudo glib-compile-schemas /usr/share/glib-2.0/schemas/
share|improve this answer
9  
There is an option in gsettings for this, com.canonical.unity-greeter play-ready-soundbut currently isn't working. One simple thing that does work is when on the greeter screen just turn the volume off in the sound indicator. The setting is persistent –  doug Apr 21 '12 at 3:26
    
@doug, thanks. The second and third sentence of your comment don't pertain this answer. I think they should go as separate answer to my question to be more visible. –  Krige Apr 21 '12 at 21:53
    
I think the answer for changing the sound permanently is currently in moving or removing this file: /usr/share/sounds/ubuntu/stereo/system-ready.ogg. See from this thread --> ubuntuforums.org/… –  e.m.fields Jun 19 '13 at 18:28
2  
@e.m.fields There's no need to resort to such a destructive hack when we have a built-in setting in support of this. Changing that setting is the cleanest solution. –  ændrük Jun 19 '13 at 20:30
1  
aendruk, I'm in favor of nondestructive solutions when they're available, but up to this point seems to have been none. What is this file? Is this a patch to an existing system application? –  e.m.fields Aug 29 '13 at 7:38

12.04 & 13.04 (LightDM)

Here is what worked for me after I installed 12.04 last week.

The steps are these:

$ gksudo gedit /usr/share/glib-2.0/schemas/50_unity-greeter.gschema.override

Add these lines:

[com.canonical.unity-greeter]
play-ready-sound = false

Save, then run:

$ sudo glib-compile-schemas /usr/share/glib-2.0/schemas/

Reboot and enjoy. I apologize that I've misplaced the link to the page that provided this information; if I have time later I will try to find it and edit this answer.

Edit: Here is the link:

http://www.liberiangeek.net/2012/05/disable-the-ready-drum-sound-in-ubuntu-12-04-precise-pangolin/

Edit2: Tested under Ubuntu 13.04. Still works fine !

share|improve this answer

If you are using GDM with 12.04

To disable the login sounds, the event-sounds key under org.gnome.desktop.sound for the gdm user must be set to false.

For this, we must first give GDM ownership of its own home directory. Open a terminal, and type: sudo chown -R gdm:gdm /var/lib/gdm

Then run:

sudo xhost +SI:localuser:gdm
sudo -u gdm gsettings set org.gnome.desktop.sound event-sounds false

and logout (or reboot).

If you are using LightDM with 12.04

Open a terminal with Ctrl+Alt+T, and type/paste the following, one line at a time:

sudo xhost +SI:localuser:lightdm
sudo su lightdm -s /bin/bash
gsettings set com.canonical.unity-greeter play-ready-sound false
exit

What this does is disable the play-ready-sound setting for the login screen/desktop manager user (lightdm).

share|improve this answer
    
Did not work for me on 12.04 with gdm. gdm settings shows 2 warnings. After reboot the sound is still being played. –  geekQ Sep 14 '12 at 8:32
    
Care to pastebin the warnings? –  izx Sep 14 '12 at 8:46
    
Warnings: pastebin.com/KTifY1Qi –  geekQ Sep 14 '12 at 18:22

11.10 (GDM)

gsettings set org.gnome.desktop.sound event-sounds false
share|improve this answer

11.10 (LightDM and GDM)

Quick solution:

Open a terminal and run the command

sudo mv /usr/share/sounds/ubuntu/stereo/desktop-login{,-disabled}.ogg  

The lightdm drum sound for system ready can be disabled in a similar fashion

sudo mv /usr/share/sounds/ubuntu/stereo/system-ready{,-disabled}.ogg  
share|improve this answer

10.10 (GDM)

There appears to be a bug in the Login Screen about this. I can't find an official report, however, this forum post confirms a fix.

Go to System/Administration/Login Screen. Unlock it, then tick "Play login sound".

Close the window, then, go back into the app again, unlock it, then untick the same option.

enter image description here

share|improve this answer

11.10 (LightDM and GDM)

This should work for you.

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Then change the NoDisplay= to false, ect.

or to remove it:

sudo rm /usr/share/sounds/ubuntu/stereo/system-ready.ogg
share|improve this answer

11.10 (LightDM and GDM)

For removing the startup sound :

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old 

For enabling the startup sound

mv /usr/share/sounds/ubuntu/stereo/system-ready.ogg.old /usr/share/sounds/ubuntu/stereo/system-ready.ogg

For removing the Login Sound (After you login) :

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old

For enabling it again :

mv /usr/share/sounds/ubuntu/stereo/desktop-login.ogg.old /usr/share/sounds/ubuntu/stereo/desktop-login.ogg
share|improve this answer
    
Note: on 12.04 with GDM moving the system-ready.ogg just changes the startup sound from original to a short beat. –  geekQ Sep 14 '12 at 8:26

12.04 (LightDM)

The LightDM bongo sound cannot be disabled via any GUI option in 12.04 and there is a bug report here:

The command line methods above can disable it.

The sound after login can easily be disabled with the answers above.

share|improve this answer

12.10 (LightDM)

Run the same command Jorge Castro gave, only with gdm replaced for lightdm:

sudo -u lightdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false
share|improve this answer

11.04 and earlier (GDM)

Run this command in a terminal?

sudo -u gdm gconftool-2 --set /desktop/gnome/sound/event_sounds --type bool false

share|improve this answer

12.10 (GDM)

None of the above works for me with gdm. If I disable the system-ready sound (the bongos), it still makes a short drum sound (one beat).

The way to disable it is:

  • Boot up, get into gdm.
  • Switch to the console (Ctrl + Alt + F1)
  • Login
  • Enter:

    export DISPLAY=:0
    sudo -H -u gdm pavucontrol
    
  • Switch back to gdm (Ctrl + Alt + F8)

  • Disable sound in the mixer. I muted it in "Playback" and "Output Devices".
  • Close the mixer, you might get an error about writing the config file, this is harmless.
  • Switch back to the console and enter

    sudo service gdm restart
    

    to test, and exit to logout.

share|improve this answer

For Ubuntu 12.04+

LightDM Way

Also known as the FluteFlute Slap, the LightDM Way involves having to logout and on the LightDM Login Screen you can change the volume or even mute the sound.

In the Login Greeter you can see the Volume on the top right. Adjusting the volume there does not affect the volume when the session starts, so you can MUTE the sound in the Greeter without muting the sound when your session starts:

enter image description here

Ubuntu Tweak Way

The Ubuntu Tweak way involves having to download the Ubuntu Tweak app and then disabling the sound from there. Do the following steps and you can do it this way:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

Open Ubuntu Tweak and on the Tweak Tab select "Login Settings" option, you should see the Play Login Sound option. Yo need to click on the Lock button above to be able to change this.

enter image description here

For Ubuntu 11.10 and Below

Go to System -> Preferences -> Startup Applications

Startup Applications

Disable the one called GNOME Login Sound

(uncheck the box and click close)

Disable the sound

you can also go to System -> Preferences -> Sound and disable the whole sound system (Like windows sounds, alerts, etc..)

In older version you could go to the Sound Preference part and select each sound and what you wanted to do. It was removed around 9.04 or 9.10. It would be good if it came back.

share|improve this answer
5  
It doesn't remember the MUTE! –  AliNa Nov 25 '12 at 23:18
1  
@AliNa - Then you have found a bug my friend. Kill it with a launchpad bug spray. You will have saved many lives in the process. –  Luis Alvarado Nov 26 '12 at 13:12
1  
@AliNa here is the bug-report for the issue. Please add your "Yes, this affects me" counting. bugs.launchpad.net/ubuntu/+source/unity-greeter/+bug/962261 –  user22153 Jun 22 '13 at 11:20

For 12.04

By default, it is turned off. To enable it, open a terminal and run

gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop

Then change the value for X-GNOME-Autostart-enabled to "true", i.e. X-GNOME-Autostart-enabled=true

For 11.10

Type on a terminal gksudo gedit /usr/share/gnome/autostart/libcanberra-login-sound.desktop and change the value NoDisplay from true to false:

enter image description here

Now go to your startup applications and you should see and be able to disable the necessary option:

enter image description here

share|improve this answer

Open the Startup Applications Preferences by searching in the Dash,

Dash search

Or from the cog,

Cog

Find the entry for GNOME Login Sound and remove the tick from the box to disable it or select it to enable it then close out.

Startup Applications

share|improve this answer
1  
well, this turns off the sound after the login, i want to turn off the sound on the login screen –  tom Mar 7 '12 at 11:07
    
@tom - you are correct, I misunderstood your question. To disable or remove the system ready sound (the drum beats) you need to follow the steps in the other posted answers, either one will work. –  Mark Rooney Mar 7 '12 at 21:29

protected by Community Sep 12 '12 at 16:08

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.