Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using Arch Linux Windows 7 And Ubuntu on the same machine, I installed first Windows 7 Then Arch Linux and Then Ubuntu.

The problem is that the grub 2 on Ubuntu is not recognizing my arch Linux installation, and I can't make it look like the arch Linux grub.

My arch Linux installation has a boot partition of about 100mb, it contains the boot stuff of arch, I can make grub 2 on arch Linux recognize the Ubuntu and windows installation so it works better.

So I want to remove the grub on Ubuntu so I can avoid problems with two grub installation on the same machine for example when Ubuntu updates grub I don't have to re-install arch Linux grub.

Thanks

share|improve this question
    
Are you asking how to uninstall Grub2 in Ubuntu? If not, then what exactly do you want to know? –  mikewhatever Jan 30 '13 at 17:14
    
@mikewhatever That is exactly what the OP said. Unless that he has been expressed wrong.. –  Lucio Jan 30 '13 at 17:47
    
I think that you should enter in Ubuntu and uninstall this software from there like any package, I hope that someone else confirm this procedure as safe. To do so: sudo apt-get purge grub* –  Lucio Jan 30 '13 at 17:56
    
@dhampir If some answer have solved your problem, you should upvote it and mark as accepted. If not, you can comment and tell us your results. –  Lucio Feb 6 '13 at 23:09

2 Answers 2

Try this please

Boot into Ubuntu and open a terminal CTRL+ALT+T

Then mount the partition with Arch Linux .. we assume is /dev/sda5 (you can find it with command sudo fdisk -l)

mount

sudo mount /dev/sda5 /mnt 

Then update grub

sudo update-grub

I'm almost certain that Arch Linux recognized now.

Above is a workaround , but when the grub be updated again the Arch Linux partition must be mounted otherwise will not recognize it.

If you want to make it permanent , you can add the contents of arch linux from /boot/grub/grub.cfg to /etc/grub.d/40_custom

If you want to install Arch Linux grub instead of Ubuntu , you can boot in Arch Linux and do

sudo grub-install /dev/sda

above command will install Arch's grub in MBR and do not forget to update it

sudo grub-mkconfig -o /boot/grub/grub.cfg

share|improve this answer

The last installed OS, which is Ubuntu, normally takes over the bootloading process. It's strange that grub in Ubuntu has failed to detect Arch Linux.

Edit: The method suggested above by NikTh to mount Arch Linux partition before updating grub might probably be the solution to this problem.

Otherwise, you have 3 options that I can think of:

  1. Manually entering a grub entry for Arch Linux, which you won't have to enter again if you include it in this file as well: /etc/grub.d/40_custom
  2. Trying Plop Boot Manager or Rescatux (via a live CD/USB) to boot Arch Linux and re-installing grub there so that it will take over the bootloading process as you wanted.
  3. Reinstalling Arch Linux so that it takes over the bootloading process as you wanted.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.